Merge pull request #19 from jjm2473/luci-i18n

fix i18n for old package
This commit is contained in:
练亮斌 2022-05-11 14:55:15 +08:00 committed by GitHub
commit a1ba535d55
No known key found for this signature in database
GPG Key ID: 4AEE18F83AFDEB23
2 changed files with 24 additions and 0 deletions

23
.github/workflows/luci.patch vendored Normal file
View File

@ -0,0 +1,23 @@
From 72f06f906ad22be173a25c3f50b61f9b1a33a16c Mon Sep 17 00:00:00 2001
From: Liangbin Lian <jjm2473@gmail.com>
Date: Fri, 11 Mar 2022 19:16:05 +0800
Subject: [PATCH] i18n compatible with old luci sources
Signed-off-by: Liangbin Lian <jjm2473@gmail.com>
---
luci.mk | 2 ++
1 file changed, 2 insertions(+)
diff --git a/luci.mk b/luci.mk
index b331ebe1c5e..7e9a823b8bd 100644
--- a/luci.mk
+++ b/luci.mk
@@ -50,6 +50,8 @@ LUCI_LANG.uk=Українська (Ukrainian)
LUCI_LANG.vi=Tiếng Việt (Vietnamese)
LUCI_LANG.zh_Hans=简体中文 (Chinese Simplified)
LUCI_LANG.zh_Hant=繁體中文 (Chinese Traditional)
+LUCI_LANG.zh-cn=$(LUCI_LANG.zh_Hans)
+LUCI_LANG.zh-tw=$(LUCI_LANG.zh_Hant)
# Submenu titles
LUCI_MENU.col=1. Collections

View File

@ -122,6 +122,7 @@ jobs:
./scripts/feeds update -a
grep -lFr '$(call KernelPackage,' feeds/base/package/linux | xargs -rn1 sed -i 's/ FILES:=/ XFILES:=/g' || true
grep -lFr '$(call KernelPackage,' feeds/base/package/kernel | xargs -rn1 sed -i 's/ FILES:=/ XFILES:=/g' || true
patch -d feeds/luci -p1 -f -i `pwd`/../apps/.github/workflows/luci.patch
if [ "$apps" = "all" ]; then
./scripts/feeds install -a -p apps -d y
for repo in `sed -e 's/src-[^ ]* \([^ ]*\) .*/\1/g' ../apps/feeds.conf`