diff --git a/applications/luci-app-bmtedge/Makefile b/applications/luci-app-bmtedge/Makefile
index 8f98b26..6c73c48 100644
--- a/applications/luci-app-bmtedge/Makefile
+++ b/applications/luci-app-bmtedge/Makefile
@@ -2,7 +2,7 @@
 
 include $(TOPDIR)/rules.mk
 
-PKG_VERSION:=1.0.1-20231020
+PKG_VERSION:=1.0.1-20231208
 PKG_RELEASE:=
 
 LUCI_TITLE:=LuCI support for bmtedge
diff --git a/applications/luci-app-bmtedge/root/usr/libexec/istorec/bmtedge.sh b/applications/luci-app-bmtedge/root/usr/libexec/istorec/bmtedge.sh
index f3a6259..f314ffe 100755
--- a/applications/luci-app-bmtedge/root/usr/libexec/istorec/bmtedge.sh
+++ b/applications/luci-app-bmtedge/root/usr/libexec/istorec/bmtedge.sh
@@ -37,7 +37,7 @@ do_install() {
     -e ksc_net=\"$netdev\" \
     -e ksc_machine_code=\"lsyK17032_$uid\" "
 
-  local tz="`uci get system.@system[0].zonename`"
+  local tz="`uci get system.@system[0].zonename | sed 's/ /_/g'`"
   [ -z "$tz" ] || cmd="$cmd -e TZ=$tz"
 
   cmd="$cmd --name bmtedge \"$image_name\""
diff --git a/applications/luci-app-chinesesubfinder/Makefile b/applications/luci-app-chinesesubfinder/Makefile
index 94b0011..cfc81b3 100644
--- a/applications/luci-app-chinesesubfinder/Makefile
+++ b/applications/luci-app-chinesesubfinder/Makefile
@@ -2,7 +2,7 @@
 
 include $(TOPDIR)/rules.mk
 
-PKG_VERSION:=1.0.2-20230215
+PKG_VERSION:=1.0.2-20231208
 PKG_RELEASE:=
 
 LUCI_TITLE:=LuCI support for ChineseSubFinder
diff --git a/applications/luci-app-chinesesubfinder/root/usr/libexec/istorec/chinesesubfinder.sh b/applications/luci-app-chinesesubfinder/root/usr/libexec/istorec/chinesesubfinder.sh
index 92b1b62..4c1f7a9 100755
--- a/applications/luci-app-chinesesubfinder/root/usr/libexec/istorec/chinesesubfinder.sh
+++ b/applications/luci-app-chinesesubfinder/root/usr/libexec/istorec/chinesesubfinder.sh
@@ -29,7 +29,7 @@ do_install() {
      --log-driver \"json-file\" \
      --log-opt \"max-size=100m\" "
 
-  local tz="`uci get system.@system[0].zonename`"
+  local tz="`uci get system.@system[0].zonename | sed 's/ /_/g'`"
   [ -z "$tz" ] || cmd="$cmd -e TZ=$tz"
 
   [ -z "$media" ] || cmd="$cmd -v \"$media:/media\""
diff --git a/applications/luci-app-codeserver/Makefile b/applications/luci-app-codeserver/Makefile
index f2c0876..e7c7ce7 100644
--- a/applications/luci-app-codeserver/Makefile
+++ b/applications/luci-app-codeserver/Makefile
@@ -2,7 +2,7 @@
 
 include $(TOPDIR)/rules.mk
 
-PKG_VERSION:=1.0.1-20230108
+PKG_VERSION:=1.0.1-20231208
 PKG_RELEASE:=
 
 LUCI_TITLE:=LuCI support for CodeServer
diff --git a/applications/luci-app-codeserver/root/usr/libexec/istorec/codeserver.sh b/applications/luci-app-codeserver/root/usr/libexec/istorec/codeserver.sh
index b38afcc..86543af 100755
--- a/applications/luci-app-codeserver/root/usr/libexec/istorec/codeserver.sh
+++ b/applications/luci-app-codeserver/root/usr/libexec/istorec/codeserver.sh
@@ -31,7 +31,7 @@ do_install() {
     -e DEFAULT_WORKSPACE=/config/workspace \
     -p $http_port:8443 "
 
-  local tz="`uci get system.@system[0].zonename`"
+  local tz="`uci get system.@system[0].zonename | sed 's/ /_/g'`"
   [ -z "$tz" ] || cmd="$cmd -e TZ=$tz"
 
   [ -z "$env_password" ] || cmd="$cmd -e \"PASSWORD=$env_password\""
diff --git a/applications/luci-app-emby/Makefile b/applications/luci-app-emby/Makefile
index f8c1af2..7b62aa5 100644
--- a/applications/luci-app-emby/Makefile
+++ b/applications/luci-app-emby/Makefile
@@ -2,7 +2,7 @@
 
 include $(TOPDIR)/rules.mk
 
-PKG_VERSION:=1.0.3-20231117
+PKG_VERSION:=1.0.3-20231208
 PKG_RELEASE:=
 
 LUCI_TITLE:=LuCI support for Emby
diff --git a/applications/luci-app-emby/root/usr/libexec/istorec/emby.sh b/applications/luci-app-emby/root/usr/libexec/istorec/emby.sh
index f2d87d7..e5df501 100755
--- a/applications/luci-app-emby/root/usr/libexec/istorec/emby.sh
+++ b/applications/luci-app-emby/root/usr/libexec/istorec/emby.sh
@@ -43,7 +43,7 @@ do_install() {
     -p $http_port:8096 "
   fi
 
-  local tz="`uci get system.@system[0].zonename`"
+  local tz="`uci get system.@system[0].zonename | sed 's/ /_/g'`"
   [ -z "$tz" ] || cmd="$cmd -e TZ=$tz"
 
   [ -z "$cache" ] || cmd="$cmd -v \"$cache:/config/cache\""
diff --git a/applications/luci-app-gogs/Makefile b/applications/luci-app-gogs/Makefile
index 2e12ce2..58c8d64 100644
--- a/applications/luci-app-gogs/Makefile
+++ b/applications/luci-app-gogs/Makefile
@@ -2,7 +2,7 @@
 
 include $(TOPDIR)/rules.mk
 
-PKG_VERSION:=1.0.1-20230108
+PKG_VERSION:=1.0.1-20231208
 PKG_RELEASE:=
 
 LUCI_TITLE:=LuCI support for Emby
diff --git a/applications/luci-app-gogs/root/usr/libexec/istorec/gogs.sh b/applications/luci-app-gogs/root/usr/libexec/istorec/gogs.sh
index e2f4585..bc02c5c 100755
--- a/applications/luci-app-gogs/root/usr/libexec/istorec/gogs.sh
+++ b/applications/luci-app-gogs/root/usr/libexec/istorec/gogs.sh
@@ -32,7 +32,7 @@ do_install() {
     -p $http_port:3000 \
     -p $ssh_port:22 "
 
-  local tz="`uci get system.@system[0].zonename`"
+  local tz="`uci get system.@system[0].zonename | sed 's/ /_/g'`"
   [ -z "$tz" ] || cmd="$cmd -e TZ=$tz"
 
   cmd="$cmd -v /mnt:/mnt"
diff --git a/applications/luci-app-heimdall/Makefile b/applications/luci-app-heimdall/Makefile
index 226812d..fe5e923 100644
--- a/applications/luci-app-heimdall/Makefile
+++ b/applications/luci-app-heimdall/Makefile
@@ -2,7 +2,7 @@
 
 include $(TOPDIR)/rules.mk
 
-PKG_VERSION:=1.1.1-20230108
+PKG_VERSION:=1.1.1-20231208
 PKG_RELEASE:=
 
 LUCI_TITLE:=LuCI support for heimdall
diff --git a/applications/luci-app-heimdall/root/usr/libexec/istorec/heimdall.sh b/applications/luci-app-heimdall/root/usr/libexec/istorec/heimdall.sh
index 905043b..b0fb637 100755
--- a/applications/luci-app-heimdall/root/usr/libexec/istorec/heimdall.sh
+++ b/applications/luci-app-heimdall/root/usr/libexec/istorec/heimdall.sh
@@ -38,7 +38,7 @@ do_install_detail() {
   cmd="$cmd -v /mnt:/mnt"
   mountpoint -q /mnt && cmd="$cmd:rslave"
 
-  local tz="`uci get system.@system[0].zonename`"
+  local tz="`uci get system.@system[0].zonename | sed 's/ /_/g'`"
   [ -z "$tz" ] || cmd="$cmd -e TZ=$tz"
 
   cmd="$cmd --name heimdall \"$IMAGE_NAME\""
diff --git a/applications/luci-app-homeassistant/Makefile b/applications/luci-app-homeassistant/Makefile
index 0175008..a7c5a17 100644
--- a/applications/luci-app-homeassistant/Makefile
+++ b/applications/luci-app-homeassistant/Makefile
@@ -2,7 +2,7 @@
 
 include $(TOPDIR)/rules.mk
 
-PKG_VERSION:=1.1.2-20230312
+PKG_VERSION:=1.1.2-20231208
 PKG_RELEASE:=
 
 LUCI_TITLE:=LuCI support for homeassistant
diff --git a/applications/luci-app-homeassistant/root/usr/libexec/istorec/homeassistant.sh b/applications/luci-app-homeassistant/root/usr/libexec/istorec/homeassistant.sh
index d23c1ce..2fe6a99 100755
--- a/applications/luci-app-homeassistant/root/usr/libexec/istorec/homeassistant.sh
+++ b/applications/luci-app-homeassistant/root/usr/libexec/istorec/homeassistant.sh
@@ -24,7 +24,7 @@ do_install() {
     --dns=127.0.0.1 "
 
   if [ -z "$tz" ]; then
-    tz="`uci get system.@system[0].zonename`"
+    tz="`uci get system.@system[0].zonename | sed 's/ /_/g'`"
   fi
   [ -z "$tz" ] || cmd="$cmd -e TZ=$tz"
 
diff --git a/applications/luci-app-jackett/Makefile b/applications/luci-app-jackett/Makefile
index f9155a5..0c4ca25 100644
--- a/applications/luci-app-jackett/Makefile
+++ b/applications/luci-app-jackett/Makefile
@@ -2,7 +2,7 @@
 
 include $(TOPDIR)/rules.mk
 
-PKG_VERSION:=1.1.1-20230108
+PKG_VERSION:=1.1.1-20231208
 PKG_RELEASE:=
 
 LUCI_TITLE:=LuCI support for jackett
diff --git a/applications/luci-app-jackett/root/usr/libexec/istorec/jackett.sh b/applications/luci-app-jackett/root/usr/libexec/istorec/jackett.sh
index 81edb46..b421007 100755
--- a/applications/luci-app-jackett/root/usr/libexec/istorec/jackett.sh
+++ b/applications/luci-app-jackett/root/usr/libexec/istorec/jackett.sh
@@ -32,7 +32,7 @@ do_install() {
     --dns=172.17.0.1 \
     -p $port:9117 "
 
-  local tz="`uci get system.@system[0].zonename`"
+  local tz="`uci get system.@system[0].zonename | sed 's/ /_/g'`"
   [ -z "$tz" ] || cmd="$cmd -e TZ=$tz"
 
   if [ -n "$auto_update" ]; then
diff --git a/applications/luci-app-jellyfin/Makefile b/applications/luci-app-jellyfin/Makefile
index 80345c9..6cf57f2 100644
--- a/applications/luci-app-jellyfin/Makefile
+++ b/applications/luci-app-jellyfin/Makefile
@@ -2,7 +2,7 @@
 
 include $(TOPDIR)/rules.mk
 
-PKG_VERSION:=1.1.8-20230619
+PKG_VERSION:=1.1.8-20231208
 PKG_RELEASE:=
 
 LUCI_TITLE:=LuCI support for jellyfin
diff --git a/applications/luci-app-jellyfin/root/usr/libexec/istorec/jellyfin.sh b/applications/luci-app-jellyfin/root/usr/libexec/istorec/jellyfin.sh
index 65a3026..74fb47d 100755
--- a/applications/luci-app-jellyfin/root/usr/libexec/istorec/jellyfin.sh
+++ b/applications/luci-app-jellyfin/root/usr/libexec/istorec/jellyfin.sh
@@ -100,7 +100,7 @@ do_install_detail() {
     -p $port:8096 "
   fi
 
-  local tz="`uci get system.@system[0].zonename`"
+  local tz="`uci get system.@system[0].zonename | sed 's/ /_/g'`"
   [ -z "$tz" ] || cmd="$cmd -e TZ=$tz"
 
   [ -z "$cache" ] || cmd="$cmd -v \"$cache:/config/transcodes\""
diff --git a/applications/luci-app-kodexplorer/Makefile b/applications/luci-app-kodexplorer/Makefile
index 2237737..0ec17f5 100644
--- a/applications/luci-app-kodexplorer/Makefile
+++ b/applications/luci-app-kodexplorer/Makefile
@@ -2,7 +2,7 @@
 
 include $(TOPDIR)/rules.mk
 
-PKG_VERSION:=1.2.1-20230108
+PKG_VERSION:=1.2.1-20231208
 PKG_RELEASE:=
 
 LUCI_TITLE:=LuCI support for kodexplorer
diff --git a/applications/luci-app-kodexplorer/root/usr/libexec/istorec/kodexplorer.sh b/applications/luci-app-kodexplorer/root/usr/libexec/istorec/kodexplorer.sh
index 90136bf..bf6733b 100755
--- a/applications/luci-app-kodexplorer/root/usr/libexec/istorec/kodexplorer.sh
+++ b/applications/luci-app-kodexplorer/root/usr/libexec/istorec/kodexplorer.sh
@@ -39,7 +39,7 @@ do_install() {
   cmd="$cmd -v /mnt:/mnt"
   mountpoint -q /mnt && cmd="$cmd:rslave"
 
-  local tz="`uci get system.@system[0].zonename`"
+  local tz="`uci get system.@system[0].zonename | sed 's/ /_/g'`"
   [ -z "$tz" ] || cmd="$cmd -e TZ=$tz"
 
   cmd="$cmd --name kodexplorer \"$IMAGE_NAME\""
diff --git a/applications/luci-app-lanraragi/Makefile b/applications/luci-app-lanraragi/Makefile
index e1fd060..f45de8c 100644
--- a/applications/luci-app-lanraragi/Makefile
+++ b/applications/luci-app-lanraragi/Makefile
@@ -2,7 +2,7 @@
 
 include $(TOPDIR)/rules.mk
 
-PKG_VERSION:=1.0.1-20230108
+PKG_VERSION:=1.0.1-20231208
 PKG_RELEASE:=
 
 LUCI_TITLE:=LuCI support for LANraragi
diff --git a/applications/luci-app-lanraragi/root/usr/libexec/istorec/lanraragi.sh b/applications/luci-app-lanraragi/root/usr/libexec/istorec/lanraragi.sh
index 6647d91..76d6612 100755
--- a/applications/luci-app-lanraragi/root/usr/libexec/istorec/lanraragi.sh
+++ b/applications/luci-app-lanraragi/root/usr/libexec/istorec/lanraragi.sh
@@ -28,7 +28,7 @@ do_install() {
     --dns=172.17.0.1 \
     -p $http_port:3000 "
 
-  local tz="`uci get system.@system[0].zonename`"
+  local tz="`uci get system.@system[0].zonename | sed 's/ /_/g'`"
   [ -z "$tz" ] || cmd="$cmd -e TZ=$tz"
 
   cmd="$cmd -v /mnt:/mnt"
diff --git a/applications/luci-app-memos/Makefile b/applications/luci-app-memos/Makefile
index 18f55e4..54fffd3 100644
--- a/applications/luci-app-memos/Makefile
+++ b/applications/luci-app-memos/Makefile
@@ -2,7 +2,7 @@
 
 include $(TOPDIR)/rules.mk
 
-PKG_VERSION:=1.0.2-20230412
+PKG_VERSION:=1.0.2-20231208
 PKG_RELEASE:=
 
 LUCI_TITLE:=LuCI support for Memos
diff --git a/applications/luci-app-memos/root/usr/libexec/istorec/memos.sh b/applications/luci-app-memos/root/usr/libexec/istorec/memos.sh
index 629143e..8b72b06 100755
--- a/applications/luci-app-memos/root/usr/libexec/istorec/memos.sh
+++ b/applications/luci-app-memos/root/usr/libexec/istorec/memos.sh
@@ -27,7 +27,7 @@ do_install() {
     --dns=172.17.0.1 \
     -p $http_port:5230 "
 
-  local tz="`uci get system.@system[0].zonename`"
+  local tz="`uci get system.@system[0].zonename | sed 's/ /_/g'`"
   [ -z "$tz" ] || cmd="$cmd -e TZ=$tz"
 
   cmd="$cmd -v /mnt:/mnt"
diff --git a/applications/luci-app-nastools/Makefile b/applications/luci-app-nastools/Makefile
index d81298d..0d1a79e 100644
--- a/applications/luci-app-nastools/Makefile
+++ b/applications/luci-app-nastools/Makefile
@@ -2,7 +2,7 @@
 
 include $(TOPDIR)/rules.mk
 
-PKG_VERSION:=1.1.3-20230215
+PKG_VERSION:=1.1.3-20231208
 PKG_RELEASE:=
 
 LUCI_TITLE:=LuCI support for nastools
diff --git a/applications/luci-app-nastools/root/usr/libexec/istorec/nastools.sh b/applications/luci-app-nastools/root/usr/libexec/istorec/nastools.sh
index 7ad977c..d460182 100755
--- a/applications/luci-app-nastools/root/usr/libexec/istorec/nastools.sh
+++ b/applications/luci-app-nastools/root/usr/libexec/istorec/nastools.sh
@@ -32,7 +32,7 @@ do_install() {
     -p $port:3000 \
     -e UMASK=000"
 
-  local tz="`uci get system.@system[0].zonename`"
+  local tz="`uci get system.@system[0].zonename | sed 's/ /_/g'`"
   [ -z "$tz" ] || cmd="$cmd -e TZ=$tz"
 
   if [ -n "$auto_update" ]; then
diff --git a/applications/luci-app-navidrome/Makefile b/applications/luci-app-navidrome/Makefile
index 405f814..34b56d4 100644
--- a/applications/luci-app-navidrome/Makefile
+++ b/applications/luci-app-navidrome/Makefile
@@ -2,7 +2,7 @@
 
 include $(TOPDIR)/rules.mk
 
-PKG_VERSION:=1.0.1-20230108
+PKG_VERSION:=1.0.1-20231208
 PKG_RELEASE:=
 
 LUCI_TITLE:=LuCI support for Navidrome
diff --git a/applications/luci-app-navidrome/root/usr/libexec/istorec/navidrome.sh b/applications/luci-app-navidrome/root/usr/libexec/istorec/navidrome.sh
index 984ea8c..1c079c8 100755
--- a/applications/luci-app-navidrome/root/usr/libexec/istorec/navidrome.sh
+++ b/applications/luci-app-navidrome/root/usr/libexec/istorec/navidrome.sh
@@ -28,7 +28,7 @@ do_install() {
     --dns=172.17.0.1 \
     -p $http_port:4533 "
 
-  local tz="`uci get system.@system[0].zonename`"
+  local tz="`uci get system.@system[0].zonename | sed 's/ /_/g'`"
   [ -z "$tz" ] || cmd="$cmd -e TZ=$tz"
 
   cmd="$cmd -v /mnt:/mnt"
diff --git a/applications/luci-app-nextcloud/Makefile b/applications/luci-app-nextcloud/Makefile
index 124d0e8..b7757c2 100644
--- a/applications/luci-app-nextcloud/Makefile
+++ b/applications/luci-app-nextcloud/Makefile
@@ -2,7 +2,7 @@
 
 include $(TOPDIR)/rules.mk
 
-PKG_VERSION:=1.1.1-20230108
+PKG_VERSION:=1.1.1-20231208
 PKG_RELEASE:=
 
 LUCI_TITLE:=LuCI support for nextcloud
diff --git a/applications/luci-app-nextcloud/root/usr/libexec/istorec/nextcloud.sh b/applications/luci-app-nextcloud/root/usr/libexec/istorec/nextcloud.sh
index a04c802..4e7f8e8 100755
--- a/applications/luci-app-nextcloud/root/usr/libexec/istorec/nextcloud.sh
+++ b/applications/luci-app-nextcloud/root/usr/libexec/istorec/nextcloud.sh
@@ -38,7 +38,7 @@ do_install() {
   cmd="$cmd -v /mnt:/mnt"
   mountpoint -q /mnt && cmd="$cmd:rslave"
 
-  local tz="`uci get system.@system[0].zonename`"
+  local tz="`uci get system.@system[0].zonename | sed 's/ /_/g'`"
   [ -z "$tz" ] || cmd="$cmd -e TZ=$tz"
 
   cmd="$cmd --name nextcloud \"$IMAGE_NAME\""
diff --git a/applications/luci-app-owntone/Makefile b/applications/luci-app-owntone/Makefile
index d05884b..7a4b9a0 100644
--- a/applications/luci-app-owntone/Makefile
+++ b/applications/luci-app-owntone/Makefile
@@ -2,7 +2,7 @@
 
 include $(TOPDIR)/rules.mk
 
-PKG_VERSION:=1.0.2-20230619
+PKG_VERSION:=1.0.2-20231208
 PKG_RELEASE:=
 
 LUCI_TITLE:=LuCI support for Owntone
diff --git a/applications/luci-app-owntone/root/usr/libexec/istorec/owntone.sh b/applications/luci-app-owntone/root/usr/libexec/istorec/owntone.sh
index 31d7352..89e46fc 100755
--- a/applications/luci-app-owntone/root/usr/libexec/istorec/owntone.sh
+++ b/applications/luci-app-owntone/root/usr/libexec/istorec/owntone.sh
@@ -25,7 +25,7 @@ do_install() {
     --dns=127.0.0.1 \
     --network=host "
 
-  local tz="`uci get system.@system[0].zonename`"
+  local tz="`uci get system.@system[0].zonename | sed 's/ /_/g'`"
   [ -z "$tz" ] || cmd="$cmd -e TZ=$tz"
 
   cmd="$cmd -v /mnt:/mnt"
diff --git a/applications/luci-app-photoprism/Makefile b/applications/luci-app-photoprism/Makefile
index 1988813..38ab47b 100644
--- a/applications/luci-app-photoprism/Makefile
+++ b/applications/luci-app-photoprism/Makefile
@@ -2,7 +2,7 @@
 
 include $(TOPDIR)/rules.mk
 
-PKG_VERSION:=1.0.3-20230804
+PKG_VERSION:=1.0.3-20231208
 PKG_RELEASE:=
 
 LUCI_TITLE:=LuCI support for PhotoPrism
diff --git a/applications/luci-app-photoprism/root/usr/libexec/istorec/photoprism.sh b/applications/luci-app-photoprism/root/usr/libexec/istorec/photoprism.sh
index 9194458..cef19ac 100755
--- a/applications/luci-app-photoprism/root/usr/libexec/istorec/photoprism.sh
+++ b/applications/luci-app-photoprism/root/usr/libexec/istorec/photoprism.sh
@@ -27,7 +27,7 @@ do_install() {
     -e PHOTOPRISM_UPLOAD_NSFW=\"true\" \
     -e PHOTOPRISM_ADMIN_PASSWORD=\"$password\" "
 
-  local tz="`uci get system.@system[0].zonename`"
+  local tz="`uci get system.@system[0].zonename | sed 's/ /_/g'`"
   [ -z "$tz" ] || cmd="$cmd -e TZ=$tz"
 
   [ -z "$picture" ] || cmd="$cmd -v \"$picture:/photoprism/originals\""
diff --git a/applications/luci-app-plex/Makefile b/applications/luci-app-plex/Makefile
index 64d6a16..d78d7aa 100644
--- a/applications/luci-app-plex/Makefile
+++ b/applications/luci-app-plex/Makefile
@@ -2,7 +2,7 @@
 
 include $(TOPDIR)/rules.mk
 
-PKG_VERSION:=1.0.2-20230619
+PKG_VERSION:=1.0.2-20231208
 PKG_RELEASE:=
 
 LUCI_TITLE:=LuCI support for Plex
diff --git a/applications/luci-app-plex/root/usr/libexec/istorec/plex.sh b/applications/luci-app-plex/root/usr/libexec/istorec/plex.sh
index c782067..29561a2 100755
--- a/applications/luci-app-plex/root/usr/libexec/istorec/plex.sh
+++ b/applications/luci-app-plex/root/usr/libexec/istorec/plex.sh
@@ -54,7 +54,7 @@ do_install() {
     -p $port:32400 "
   fi
 
-  local tz="`uci get system.@system[0].zonename`"
+  local tz="`uci get system.@system[0].zonename | sed 's/ /_/g'`"
   [ -z "$tz" ] || cmd="$cmd -e TZ=$tz"
 
   [ -z "$claim_token" ] || cmd="$cmd -e \"PLEX_CLAIM=$claim_token\""
diff --git a/applications/luci-app-ubuntu/Makefile b/applications/luci-app-ubuntu/Makefile
index 275906a..6f30042 100644
--- a/applications/luci-app-ubuntu/Makefile
+++ b/applications/luci-app-ubuntu/Makefile
@@ -2,7 +2,7 @@
 
 include $(TOPDIR)/rules.mk
 
-PKG_VERSION:=1.1.1-20230108
+PKG_VERSION:=1.1.1-20231208
 PKG_RELEASE:=
 
 LUCI_TITLE:=LuCI support for ubuntu
diff --git a/applications/luci-app-ubuntu/root/usr/libexec/istorec/ubuntu.sh b/applications/luci-app-ubuntu/root/usr/libexec/istorec/ubuntu.sh
index c66bf24..12ef505 100755
--- a/applications/luci-app-ubuntu/root/usr/libexec/istorec/ubuntu.sh
+++ b/applications/luci-app-ubuntu/root/usr/libexec/istorec/ubuntu.sh
@@ -44,7 +44,7 @@ do_install() {
     -e VNC_PW=${password} \
     -e VNC_USE_HTTP=0 "
 
-  local tz="`uci get system.@system[0].zonename`"
+  local tz="`uci get system.@system[0].zonename | sed 's/ /_/g'`"
   [ -z "$tz" ] || cmd="$cmd -e TZ=$tz"
 
   cmd="$cmd -v /mnt:/mnt"
diff --git a/applications/luci-app-unifi/Makefile b/applications/luci-app-unifi/Makefile
index b314aab..3956cd0 100644
--- a/applications/luci-app-unifi/Makefile
+++ b/applications/luci-app-unifi/Makefile
@@ -2,7 +2,7 @@
 
 include $(TOPDIR)/rules.mk
 
-PKG_VERSION:=1.0.2-20230619
+PKG_VERSION:=1.0.2-20231208
 PKG_RELEASE:=
 
 LUCI_TITLE:=LuCI support for UnifiController
diff --git a/applications/luci-app-unifi/root/usr/libexec/istorec/unifi.sh b/applications/luci-app-unifi/root/usr/libexec/istorec/unifi.sh
index c490395..9fd3308 100755
--- a/applications/luci-app-unifi/root/usr/libexec/istorec/unifi.sh
+++ b/applications/luci-app-unifi/root/usr/libexec/istorec/unifi.sh
@@ -37,7 +37,7 @@ do_install() {
     -p $http_port:8443 "
   fi
 
-  local tz="`uci get system.@system[0].zonename`"
+  local tz="`uci get system.@system[0].zonename | sed 's/ /_/g'`"
   [ -z "$tz" ] || cmd="$cmd -e TZ=$tz"
 
   cmd="$cmd -v /mnt:/mnt"
diff --git a/applications/luci-app-vaultwarden/Makefile b/applications/luci-app-vaultwarden/Makefile
index 6fdee53..47c5653 100644
--- a/applications/luci-app-vaultwarden/Makefile
+++ b/applications/luci-app-vaultwarden/Makefile
@@ -2,7 +2,7 @@
 
 include $(TOPDIR)/rules.mk
 
-PKG_VERSION:=1.0.1-20230108
+PKG_VERSION:=1.0.1-20231208
 PKG_RELEASE:=
 
 LUCI_TITLE:=LuCI support for Vaultwarden
diff --git a/applications/luci-app-vaultwarden/root/usr/libexec/istorec/vaultwarden.sh b/applications/luci-app-vaultwarden/root/usr/libexec/istorec/vaultwarden.sh
index ea3fc8a..2de5432 100755
--- a/applications/luci-app-vaultwarden/root/usr/libexec/istorec/vaultwarden.sh
+++ b/applications/luci-app-vaultwarden/root/usr/libexec/istorec/vaultwarden.sh
@@ -37,7 +37,7 @@ do_install() {
     cmd="$cmd -e \"SIGNUPS_ALLOWED=false\""
   fi
 
-  local tz="`uci get system.@system[0].zonename`"
+  local tz="`uci get system.@system[0].zonename | sed 's/ /_/g'`"
   [ -z "$tz" ] || cmd="$cmd -e TZ=$tz"
 
   cmd="$cmd -v /mnt:/mnt"
diff --git a/applications/luci-app-webvirtcloud/Makefile b/applications/luci-app-webvirtcloud/Makefile
index 22d71f5..6137ed7 100644
--- a/applications/luci-app-webvirtcloud/Makefile
+++ b/applications/luci-app-webvirtcloud/Makefile
@@ -2,7 +2,7 @@
 
 include $(TOPDIR)/rules.mk
 
-PKG_VERSION:=0.3.8-20231208
+PKG_VERSION:=0.3.8-20231208-1
 PKG_RELEASE:=
 
 LUCI_TITLE:=LuCI support for webvirtcloud
diff --git a/applications/luci-app-webvirtcloud/root/usr/libexec/istorec/webvirtcloud.sh b/applications/luci-app-webvirtcloud/root/usr/libexec/istorec/webvirtcloud.sh
index 2e57c70..6bc3408 100755
--- a/applications/luci-app-webvirtcloud/root/usr/libexec/istorec/webvirtcloud.sh
+++ b/applications/luci-app-webvirtcloud/root/usr/libexec/istorec/webvirtcloud.sh
@@ -39,7 +39,7 @@ do_install() {
     --dns=223.5.5.5 "
 
   if [ -z "$tz" ]; then
-    tz="`uci get system.@system[0].zonename`"
+    tz="`uci get system.@system[0].zonename | sed 's/ /_/g'`"
   fi
   [ -z "$tz" ] || cmd="$cmd -e TZ=\"$tz\""
 
diff --git a/applications/luci-app-wxedge/Makefile b/applications/luci-app-wxedge/Makefile
index bd77ec3..f56785d 100644
--- a/applications/luci-app-wxedge/Makefile
+++ b/applications/luci-app-wxedge/Makefile
@@ -2,7 +2,7 @@
 
 include $(TOPDIR)/rules.mk
 
-PKG_VERSION:=1.1.3-20230614
+PKG_VERSION:=1.1.3-20231208
 PKG_RELEASE:=
 
 LUCI_TITLE:=LuCI support for wxedge
diff --git a/applications/luci-app-wxedge/root/usr/libexec/istorec/wxedge.sh b/applications/luci-app-wxedge/root/usr/libexec/istorec/wxedge.sh
index aa28f7e..f615d35 100755
--- a/applications/luci-app-wxedge/root/usr/libexec/istorec/wxedge.sh
+++ b/applications/luci-app-wxedge/root/usr/libexec/istorec/wxedge.sh
@@ -27,7 +27,7 @@ do_install() {
     -v \"$path/containerd:/var/lib/containerd\" \
     -e PLACE=CTKS"
 
-  local tz="`uci get system.@system[0].zonename`"
+  local tz="`uci get system.@system[0].zonename | sed 's/ /_/g'`"
   [ -z "$tz" ] || cmd="$cmd -e TZ=$tz"
 
   cmd="$cmd --name wxedge \"$image_name\""
diff --git a/applications/luci-app-xteve/Makefile b/applications/luci-app-xteve/Makefile
index 92a596e..751f1bf 100644
--- a/applications/luci-app-xteve/Makefile
+++ b/applications/luci-app-xteve/Makefile
@@ -2,7 +2,7 @@
 
 include $(TOPDIR)/rules.mk
 
-PKG_VERSION:=1.0.2-20230619
+PKG_VERSION:=1.0.2-20231208
 PKG_RELEASE:=
 
 LUCI_TITLE:=LuCI support for Xteve
diff --git a/applications/luci-app-xteve/root/usr/libexec/istorec/xteve.sh b/applications/luci-app-xteve/root/usr/libexec/istorec/xteve.sh
index aa95d8e..fda794f 100755
--- a/applications/luci-app-xteve/root/usr/libexec/istorec/xteve.sh
+++ b/applications/luci-app-xteve/root/usr/libexec/istorec/xteve.sh
@@ -37,7 +37,7 @@ do_install() {
     -p $port:34400 "
 
   if [ -z "$tz" ]; then
-    tz="`uci get system.@system[0].zonename`"
+    tz="`uci get system.@system[0].zonename | sed 's/ /_/g'`"
   fi
   [ -z "$tz" ] || cmd="$cmd -e TZ=$tz"
 
diff --git a/applications/luci-app-xunlei/Makefile b/applications/luci-app-xunlei/Makefile
index db1a2f7..fe3e2bc 100644
--- a/applications/luci-app-xunlei/Makefile
+++ b/applications/luci-app-xunlei/Makefile
@@ -2,7 +2,7 @@
 
 include $(TOPDIR)/rules.mk
 
-PKG_VERSION:=1.0.2-20230619
+PKG_VERSION:=1.0.2-20231208
 PKG_RELEASE:=
 
 LUCI_TITLE:=LuCI support for Xunlei
diff --git a/applications/luci-app-xunlei/root/usr/libexec/istorec/xunlei.sh b/applications/luci-app-xunlei/root/usr/libexec/istorec/xunlei.sh
index af37871..bd94dee 100755
--- a/applications/luci-app-xunlei/root/usr/libexec/istorec/xunlei.sh
+++ b/applications/luci-app-xunlei/root/usr/libexec/istorec/xunlei.sh
@@ -37,7 +37,7 @@ do_install() {
     -p $port:2345 "
   fi
 
-  local tz="`uci get system.@system[0].zonename`"
+  local tz="`uci get system.@system[0].zonename | sed 's/ /_/g'`"
   [ -z "$tz" ] || cmd="$cmd -e TZ=$tz"
 
   cmd="$cmd --name xunlei \"$image_name\""