wolfssl: Update to v4.6.0-stable
This version fixes a large number of bugs and fixes CVE-2020-36177. Full changelog at: https://www.wolfssl.com/docs/wolfssl-changelog/ or, as part of the version's README.md: https://github.com/wolfSSL/wolfssl/blob/v4.6.0-stable/README.md Due a number of API additions, size increases from 374.7K to 408.8K for arm_cortex_a9_vfpv3-d16. The ABI does not change from previous version. Backported patches were removed; remaining patch was refreshed. Signed-off-by: Eneas U de Queiroz <cotequeiroz@gmail.com> [added reference to CVE] Signed-off-by: Petr Štetiar <ynezz@true.cz> (cherry picked from commit ba40da9045f77feb04abe63eb8a92f13f9efe471)
This commit is contained in:
parent
5ac0b2b431
commit
2044c01de8
@ -8,12 +8,12 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=wolfssl
|
PKG_NAME:=wolfssl
|
||||||
PKG_VERSION:=4.5.0-stable
|
PKG_VERSION:=4.6.0-stable
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=https://github.com/wolfSSL/wolfssl/archive/v$(PKG_VERSION)
|
PKG_SOURCE_URL:=https://github.com/wolfSSL/wolfssl/archive/v$(PKG_VERSION)
|
||||||
PKG_HASH:=7de62300ce14daa0051bfefc7c4d6302f96cabc768b6ae49eda77523b118250c
|
PKG_HASH:=053aefbb02d0b06b27c5e2df6875b4b587318755b7db9d6aa8d72206b310a848
|
||||||
|
|
||||||
PKG_FIXUP:=libtool
|
PKG_FIXUP:=libtool
|
||||||
PKG_INSTALL:=1
|
PKG_INSTALL:=1
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
--- a/wolfssl/wolfcrypt/settings.h
|
--- a/wolfssl/wolfcrypt/settings.h
|
||||||
+++ b/wolfssl/wolfcrypt/settings.h
|
+++ b/wolfssl/wolfcrypt/settings.h
|
||||||
@@ -2128,7 +2128,7 @@ extern void uITRON4_free(void *p) ;
|
@@ -2248,7 +2248,7 @@ extern void uITRON4_free(void *p) ;
|
||||||
#endif
|
#endif
|
||||||
|
|
||||||
/* warning for not using harden build options (default with ./configure) */
|
/* warning for not using harden build options (default with ./configure) */
|
||||||
|
@ -1,27 +0,0 @@
|
|||||||
From b90acc91d0cd276befe7f08f87ba2dc5ee7122ff Mon Sep 17 00:00:00 2001
|
|
||||||
From: Tesfa Mael <tesfa@wolfssl.com>
|
|
||||||
Date: Wed, 26 Aug 2020 10:13:06 -0700
|
|
||||||
Subject: [PATCH] Make ByteReverseWords available for big and little endian
|
|
||||||
|
|
||||||
---
|
|
||||||
wolfcrypt/src/misc.c | 2 --
|
|
||||||
1 file changed, 2 deletions(-)
|
|
||||||
|
|
||||||
--- a/wolfcrypt/src/misc.c
|
|
||||||
+++ b/wolfcrypt/src/misc.c
|
|
||||||
@@ -120,7 +120,6 @@ WC_STATIC WC_INLINE word32 ByteReverseWo
|
|
||||||
return rotlFixed(value, 16U);
|
|
||||||
#endif
|
|
||||||
}
|
|
||||||
-#if defined(LITTLE_ENDIAN_ORDER)
|
|
||||||
/* This routine performs a byte swap of words array of a given count. */
|
|
||||||
WC_STATIC WC_INLINE void ByteReverseWords(word32* out, const word32* in,
|
|
||||||
word32 byteCount)
|
|
||||||
@@ -131,7 +130,6 @@ WC_STATIC WC_INLINE void ByteReverseWord
|
|
||||||
out[i] = ByteReverseWord32(in[i]);
|
|
||||||
|
|
||||||
}
|
|
||||||
-#endif /* LITTLE_ENDIAN_ORDER */
|
|
||||||
|
|
||||||
#if defined(WORD64_AVAILABLE) && !defined(WOLFSSL_NO_WORD64_OPS)
|
|
||||||
|
|
Loading…
x
Reference in New Issue
Block a user