mac80211: Update to version 4.19.66-1
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
This commit is contained in:
parent
ac7ccf739a
commit
3809b6662d
@ -10,10 +10,10 @@ include $(INCLUDE_DIR)/kernel.mk
|
|||||||
|
|
||||||
PKG_NAME:=mac80211
|
PKG_NAME:=mac80211
|
||||||
|
|
||||||
PKG_VERSION:=4.19.57-1
|
PKG_VERSION:=4.19.66-1
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
PKG_SOURCE_URL:=@KERNEL/linux/kernel/projects/backports/stable/v4.19.57/
|
PKG_SOURCE_URL:=@KERNEL/linux/kernel/projects/backports/stable/v4.19.66/
|
||||||
PKG_HASH:=f9c2d888cd49bd85e3f625f440468a803eeabb36662b56426c6cb2d15a7e049d
|
PKG_HASH:=1f3c6a58cb45b247f6e473d1b52236bfbb41cb3e11e38a74526727e911b51a02
|
||||||
|
|
||||||
PKG_SOURCE:=backports-$(PKG_VERSION).tar.xz
|
PKG_SOURCE:=backports-$(PKG_VERSION).tar.xz
|
||||||
PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/backports-$(PKG_VERSION)
|
PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/backports-$(PKG_VERSION)
|
||||||
|
@ -9,7 +9,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
|
|||||||
|
|
||||||
--- a/drivers/net/wireless/ath/ath9k/hw.c
|
--- a/drivers/net/wireless/ath/ath9k/hw.c
|
||||||
+++ b/drivers/net/wireless/ath/ath9k/hw.c
|
+++ b/drivers/net/wireless/ath/ath9k/hw.c
|
||||||
@@ -1421,8 +1421,12 @@ static bool ath9k_hw_set_reset(struct at
|
@@ -1435,8 +1435,12 @@ static bool ath9k_hw_set_reset(struct at
|
||||||
if (!AR_SREV_9100(ah))
|
if (!AR_SREV_9100(ah))
|
||||||
REG_WRITE(ah, AR_RC, 0);
|
REG_WRITE(ah, AR_RC, 0);
|
||||||
|
|
||||||
|
@ -10,7 +10,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
|
|||||||
|
|
||||||
--- a/drivers/net/wireless/ath/ath9k/hw.c
|
--- a/drivers/net/wireless/ath/ath9k/hw.c
|
||||||
+++ b/drivers/net/wireless/ath/ath9k/hw.c
|
+++ b/drivers/net/wireless/ath/ath9k/hw.c
|
||||||
@@ -1298,39 +1298,56 @@ void ath9k_hw_get_delta_slope_vals(struc
|
@@ -1312,39 +1312,56 @@ void ath9k_hw_get_delta_slope_vals(struc
|
||||||
*coef_exponent = coef_exp - 16;
|
*coef_exponent = coef_exp - 16;
|
||||||
}
|
}
|
||||||
|
|
||||||
@ -94,7 +94,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
|
|||||||
return true;
|
return true;
|
||||||
}
|
}
|
||||||
|
|
||||||
@@ -1383,24 +1400,24 @@ static bool ath9k_hw_set_reset(struct at
|
@@ -1397,24 +1414,24 @@ static bool ath9k_hw_set_reset(struct at
|
||||||
rst_flags |= AR_RTC_RC_MAC_COLD;
|
rst_flags |= AR_RTC_RC_MAC_COLD;
|
||||||
}
|
}
|
||||||
|
|
||||||
|
@ -8,7 +8,7 @@ This reverts commit 71f5137bf010c6faffab50c0ec15374c59c4a411.
|
|||||||
|
|
||||||
--- a/drivers/net/wireless/ath/ath9k/hw.c
|
--- a/drivers/net/wireless/ath/ath9k/hw.c
|
||||||
+++ b/drivers/net/wireless/ath/ath9k/hw.c
|
+++ b/drivers/net/wireless/ath/ath9k/hw.c
|
||||||
@@ -2962,7 +2962,8 @@ void ath9k_hw_apply_txpower(struct ath_h
|
@@ -2976,7 +2976,8 @@ void ath9k_hw_apply_txpower(struct ath_h
|
||||||
{
|
{
|
||||||
struct ath_regulatory *reg = ath9k_hw_regulatory(ah);
|
struct ath_regulatory *reg = ath9k_hw_regulatory(ah);
|
||||||
struct ieee80211_channel *channel;
|
struct ieee80211_channel *channel;
|
||||||
@ -18,7 +18,7 @@ This reverts commit 71f5137bf010c6faffab50c0ec15374c59c4a411.
|
|||||||
u16 ctl = NO_CTL;
|
u16 ctl = NO_CTL;
|
||||||
|
|
||||||
if (!chan)
|
if (!chan)
|
||||||
@@ -2974,9 +2975,14 @@ void ath9k_hw_apply_txpower(struct ath_h
|
@@ -2988,9 +2989,14 @@ void ath9k_hw_apply_txpower(struct ath_h
|
||||||
channel = chan->chan;
|
channel = chan->chan;
|
||||||
chan_pwr = min_t(int, channel->max_power * 2, MAX_RATE_POWER);
|
chan_pwr = min_t(int, channel->max_power * 2, MAX_RATE_POWER);
|
||||||
new_pwr = min_t(int, chan_pwr, reg->power_limit);
|
new_pwr = min_t(int, chan_pwr, reg->power_limit);
|
||||||
|
@ -11,7 +11,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
|
|||||||
|
|
||||||
--- a/drivers/net/wireless/ath/ath9k/hw.c
|
--- a/drivers/net/wireless/ath/ath9k/hw.c
|
||||||
+++ b/drivers/net/wireless/ath/ath9k/hw.c
|
+++ b/drivers/net/wireless/ath/ath9k/hw.c
|
||||||
@@ -2981,6 +2981,10 @@ void ath9k_hw_apply_txpower(struct ath_h
|
@@ -2995,6 +2995,10 @@ void ath9k_hw_apply_txpower(struct ath_h
|
||||||
if (ant_gain > max_gain)
|
if (ant_gain > max_gain)
|
||||||
ant_reduction = ant_gain - max_gain;
|
ant_reduction = ant_gain - max_gain;
|
||||||
|
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
--- a/drivers/net/wireless/ath/ath9k/hw.c
|
--- a/drivers/net/wireless/ath/ath9k/hw.c
|
||||||
+++ b/drivers/net/wireless/ath/ath9k/hw.c
|
+++ b/drivers/net/wireless/ath/ath9k/hw.c
|
||||||
@@ -392,13 +392,8 @@ static void ath9k_hw_init_config(struct
|
@@ -403,13 +403,8 @@ static void ath9k_hw_init_config(struct
|
||||||
|
|
||||||
ah->config.rx_intr_mitigation = true;
|
ah->config.rx_intr_mitigation = true;
|
||||||
|
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
--- a/drivers/net/wireless/ath/ath9k/hw.c
|
--- a/drivers/net/wireless/ath/ath9k/hw.c
|
||||||
+++ b/drivers/net/wireless/ath/ath9k/hw.c
|
+++ b/drivers/net/wireless/ath/ath9k/hw.c
|
||||||
@@ -649,6 +649,7 @@ int ath9k_hw_init(struct ath_hw *ah)
|
@@ -663,6 +663,7 @@ int ath9k_hw_init(struct ath_hw *ah)
|
||||||
|
|
||||||
/* These are all the AR5008/AR9001/AR9002/AR9003 hardware family of chipsets */
|
/* These are all the AR5008/AR9001/AR9002/AR9003 hardware family of chipsets */
|
||||||
switch (ah->hw_version.devid) {
|
switch (ah->hw_version.devid) {
|
||||||
|
@ -94,7 +94,7 @@
|
|||||||
struct ath_gen_timer *ath_gen_timer_alloc(struct ath_hw *ah,
|
struct ath_gen_timer *ath_gen_timer_alloc(struct ath_hw *ah,
|
||||||
--- a/drivers/net/wireless/ath/ath9k/hw.c
|
--- a/drivers/net/wireless/ath/ath9k/hw.c
|
||||||
+++ b/drivers/net/wireless/ath/ath9k/hw.c
|
+++ b/drivers/net/wireless/ath/ath9k/hw.c
|
||||||
@@ -1869,6 +1869,20 @@ u32 ath9k_hw_get_tsf_offset(struct times
|
@@ -1883,6 +1883,20 @@ u32 ath9k_hw_get_tsf_offset(struct times
|
||||||
}
|
}
|
||||||
EXPORT_SYMBOL(ath9k_hw_get_tsf_offset);
|
EXPORT_SYMBOL(ath9k_hw_get_tsf_offset);
|
||||||
|
|
||||||
@ -115,7 +115,7 @@
|
|||||||
int ath9k_hw_reset(struct ath_hw *ah, struct ath9k_channel *chan,
|
int ath9k_hw_reset(struct ath_hw *ah, struct ath9k_channel *chan,
|
||||||
struct ath9k_hw_cal_data *caldata, bool fastcc)
|
struct ath9k_hw_cal_data *caldata, bool fastcc)
|
||||||
{
|
{
|
||||||
@@ -2077,6 +2091,7 @@ int ath9k_hw_reset(struct ath_hw *ah, st
|
@@ -2091,6 +2105,7 @@ int ath9k_hw_reset(struct ath_hw *ah, st
|
||||||
ar9003_hw_disable_phy_restart(ah);
|
ar9003_hw_disable_phy_restart(ah);
|
||||||
|
|
||||||
ath9k_hw_apply_gpio_override(ah);
|
ath9k_hw_apply_gpio_override(ah);
|
||||||
|
@ -20,7 +20,7 @@
|
|||||||
/******************/
|
/******************/
|
||||||
/* Chip Revisions */
|
/* Chip Revisions */
|
||||||
/******************/
|
/******************/
|
||||||
@@ -1441,6 +1454,9 @@ static bool ath9k_hw_set_reset(struct at
|
@@ -1455,6 +1468,9 @@ static bool ath9k_hw_set_reset(struct at
|
||||||
udelay(50);
|
udelay(50);
|
||||||
}
|
}
|
||||||
|
|
||||||
@ -30,7 +30,7 @@
|
|||||||
return true;
|
return true;
|
||||||
}
|
}
|
||||||
|
|
||||||
@@ -1540,6 +1556,9 @@ static bool ath9k_hw_chip_reset(struct a
|
@@ -1554,6 +1570,9 @@ static bool ath9k_hw_chip_reset(struct a
|
||||||
ar9003_hw_internal_regulator_apply(ah);
|
ar9003_hw_internal_regulator_apply(ah);
|
||||||
ath9k_hw_init_pll(ah, chan);
|
ath9k_hw_init_pll(ah, chan);
|
||||||
|
|
||||||
@ -40,7 +40,7 @@
|
|||||||
return true;
|
return true;
|
||||||
}
|
}
|
||||||
|
|
||||||
@@ -1847,8 +1866,14 @@ static int ath9k_hw_do_fastcc(struct ath
|
@@ -1861,8 +1880,14 @@ static int ath9k_hw_do_fastcc(struct ath
|
||||||
if (AR_SREV_9271(ah))
|
if (AR_SREV_9271(ah))
|
||||||
ar9002_hw_load_ani_reg(ah, chan);
|
ar9002_hw_load_ani_reg(ah, chan);
|
||||||
|
|
||||||
@ -55,7 +55,7 @@
|
|||||||
return -EINVAL;
|
return -EINVAL;
|
||||||
}
|
}
|
||||||
|
|
||||||
@@ -2102,6 +2127,9 @@ int ath9k_hw_reset(struct ath_hw *ah, st
|
@@ -2116,6 +2141,9 @@ int ath9k_hw_reset(struct ath_hw *ah, st
|
||||||
ath9k_hw_set_radar_params(ah);
|
ath9k_hw_set_radar_params(ah);
|
||||||
}
|
}
|
||||||
|
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
--- a/drivers/net/wireless/ath/ath10k/mac.c
|
--- a/drivers/net/wireless/ath/ath10k/mac.c
|
||||||
+++ b/drivers/net/wireless/ath/ath10k/mac.c
|
+++ b/drivers/net/wireless/ath/ath10k/mac.c
|
||||||
@@ -8282,6 +8282,21 @@ static int ath10k_mac_init_rd(struct ath
|
@@ -8286,6 +8286,21 @@ static int ath10k_mac_init_rd(struct ath
|
||||||
return 0;
|
return 0;
|
||||||
}
|
}
|
||||||
|
|
||||||
@ -22,7 +22,7 @@
|
|||||||
int ath10k_mac_register(struct ath10k *ar)
|
int ath10k_mac_register(struct ath10k *ar)
|
||||||
{
|
{
|
||||||
static const u32 cipher_suites[] = {
|
static const u32 cipher_suites[] = {
|
||||||
@@ -8571,6 +8586,12 @@ int ath10k_mac_register(struct ath10k *a
|
@@ -8575,6 +8590,12 @@ int ath10k_mac_register(struct ath10k *a
|
||||||
|
|
||||||
wiphy_ext_feature_set(ar->hw->wiphy, NL80211_EXT_FEATURE_CQM_RSSI_LIST);
|
wiphy_ext_feature_set(ar->hw->wiphy, NL80211_EXT_FEATURE_CQM_RSSI_LIST);
|
||||||
|
|
||||||
|
@ -23,7 +23,7 @@ v9: use SM/MS macros from code.h to simplify shift/mask handling
|
|||||||
3 files changed, 52 insertions(+), 23 deletions(-)
|
3 files changed, 52 insertions(+), 23 deletions(-)
|
||||||
--- a/drivers/net/wireless/ath/ath10k/mac.c
|
--- a/drivers/net/wireless/ath/ath10k/mac.c
|
||||||
+++ b/drivers/net/wireless/ath/ath10k/mac.c
|
+++ b/drivers/net/wireless/ath/ath10k/mac.c
|
||||||
@@ -2469,7 +2469,7 @@ static void ath10k_peer_assoc_h_vht(stru
|
@@ -2473,7 +2473,7 @@ static void ath10k_peer_assoc_h_vht(stru
|
||||||
const u16 *vht_mcs_mask;
|
const u16 *vht_mcs_mask;
|
||||||
u8 ampdu_factor;
|
u8 ampdu_factor;
|
||||||
u8 max_nss, vht_mcs;
|
u8 max_nss, vht_mcs;
|
||||||
@ -32,7 +32,7 @@ v9: use SM/MS macros from code.h to simplify shift/mask handling
|
|||||||
|
|
||||||
if (WARN_ON(ath10k_mac_vif_chan(vif, &def)))
|
if (WARN_ON(ath10k_mac_vif_chan(vif, &def)))
|
||||||
return;
|
return;
|
||||||
@@ -2529,23 +2529,45 @@ static void ath10k_peer_assoc_h_vht(stru
|
@@ -2533,23 +2533,45 @@ static void ath10k_peer_assoc_h_vht(stru
|
||||||
__le16_to_cpu(vht_cap->vht_mcs.tx_highest);
|
__le16_to_cpu(vht_cap->vht_mcs.tx_highest);
|
||||||
arg->peer_vht_rates.tx_mcs_set = ath10k_peer_assoc_h_vht_limit(
|
arg->peer_vht_rates.tx_mcs_set = ath10k_peer_assoc_h_vht_limit(
|
||||||
__le16_to_cpu(vht_cap->vht_mcs.tx_mcs_map), vht_mcs_mask);
|
__le16_to_cpu(vht_cap->vht_mcs.tx_mcs_map), vht_mcs_mask);
|
||||||
@ -92,7 +92,7 @@ v9: use SM/MS macros from code.h to simplify shift/mask handling
|
|||||||
}
|
}
|
||||||
|
|
||||||
static void ath10k_peer_assoc_h_qos(struct ath10k *ar,
|
static void ath10k_peer_assoc_h_qos(struct ath10k *ar,
|
||||||
@@ -2697,9 +2719,9 @@ static int ath10k_peer_assoc_prepare(str
|
@@ -2701,9 +2723,9 @@ static int ath10k_peer_assoc_prepare(str
|
||||||
ath10k_peer_assoc_h_crypto(ar, vif, sta, arg);
|
ath10k_peer_assoc_h_crypto(ar, vif, sta, arg);
|
||||||
ath10k_peer_assoc_h_rates(ar, vif, sta, arg);
|
ath10k_peer_assoc_h_rates(ar, vif, sta, arg);
|
||||||
ath10k_peer_assoc_h_ht(ar, vif, sta, arg);
|
ath10k_peer_assoc_h_ht(ar, vif, sta, arg);
|
||||||
|
@ -13,7 +13,7 @@ v2: fix trailing whitespace issue and fix some typos within the commit note
|
|||||||
2 files changed, 8 insertions(+), 10 deletions(-)
|
2 files changed, 8 insertions(+), 10 deletions(-)
|
||||||
--- a/drivers/net/wireless/ath/ath10k/mac.c
|
--- a/drivers/net/wireless/ath/ath10k/mac.c
|
||||||
+++ b/drivers/net/wireless/ath/ath10k/mac.c
|
+++ b/drivers/net/wireless/ath/ath10k/mac.c
|
||||||
@@ -4473,13 +4473,6 @@ static struct ieee80211_sta_vht_cap ath1
|
@@ -4477,13 +4477,6 @@ static struct ieee80211_sta_vht_cap ath1
|
||||||
vht_cap.cap |= val;
|
vht_cap.cap |= val;
|
||||||
}
|
}
|
||||||
|
|
||||||
|
@ -42,7 +42,7 @@ Signed-off-by: Mathias Kresin <dev@kresin.me>
|
|||||||
if (ret)
|
if (ret)
|
||||||
--- a/drivers/net/wireless/ath/ath10k/mac.c
|
--- a/drivers/net/wireless/ath/ath10k/mac.c
|
||||||
+++ b/drivers/net/wireless/ath/ath10k/mac.c
|
+++ b/drivers/net/wireless/ath/ath10k/mac.c
|
||||||
@@ -8603,7 +8603,7 @@ int ath10k_mac_register(struct ath10k *a
|
@@ -8607,7 +8607,7 @@ int ath10k_mac_register(struct ath10k *a
|
||||||
wiphy_ext_feature_set(ar->hw->wiphy, NL80211_EXT_FEATURE_CQM_RSSI_LIST);
|
wiphy_ext_feature_set(ar->hw->wiphy, NL80211_EXT_FEATURE_CQM_RSSI_LIST);
|
||||||
|
|
||||||
#ifdef CPTCFG_MAC80211_LEDS
|
#ifdef CPTCFG_MAC80211_LEDS
|
||||||
|
@ -29,7 +29,7 @@ Forwarded: https://patchwork.kernel.org/patch/10549245/
|
|||||||
#include <net/mac80211.h>
|
#include <net/mac80211.h>
|
||||||
#include <linux/etherdevice.h>
|
#include <linux/etherdevice.h>
|
||||||
#include <linux/acpi.h>
|
#include <linux/acpi.h>
|
||||||
@@ -8390,6 +8391,7 @@ int ath10k_mac_register(struct ath10k *a
|
@@ -8394,6 +8395,7 @@ int ath10k_mac_register(struct ath10k *a
|
||||||
ar->hw->wiphy->bands[NL80211_BAND_5GHZ] = band;
|
ar->hw->wiphy->bands[NL80211_BAND_5GHZ] = band;
|
||||||
}
|
}
|
||||||
|
|
||||||
|
@ -43,7 +43,7 @@ Origin: backport, https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux
|
|||||||
static int ath10k_mac_get_max_vht_mcs_map(u16 mcs_map, int nss)
|
static int ath10k_mac_get_max_vht_mcs_map(u16 mcs_map, int nss)
|
||||||
{
|
{
|
||||||
switch ((mcs_map >> (2 * nss)) & 0x3) {
|
switch ((mcs_map >> (2 * nss)) & 0x3) {
|
||||||
@@ -5468,9 +5484,10 @@ static void ath10k_bss_info_changed(stru
|
@@ -5472,9 +5488,10 @@ static void ath10k_bss_info_changed(stru
|
||||||
struct cfg80211_chan_def def;
|
struct cfg80211_chan_def def;
|
||||||
u32 vdev_param, pdev_param, slottime, preamble;
|
u32 vdev_param, pdev_param, slottime, preamble;
|
||||||
u16 bitrate, hw_value;
|
u16 bitrate, hw_value;
|
||||||
@ -56,7 +56,7 @@ Origin: backport, https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux
|
|||||||
|
|
||||||
mutex_lock(&ar->conf_mutex);
|
mutex_lock(&ar->conf_mutex);
|
||||||
|
|
||||||
@@ -5676,6 +5693,30 @@ static void ath10k_bss_info_changed(stru
|
@@ -5680,6 +5697,30 @@ static void ath10k_bss_info_changed(stru
|
||||||
arvif->vdev_id, ret);
|
arvif->vdev_id, ret);
|
||||||
}
|
}
|
||||||
|
|
||||||
|
@ -26,7 +26,7 @@ Origin: backport, https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux
|
|||||||
if (ath10k_rates[i].bitrate == bitrate)
|
if (ath10k_rates[i].bitrate == bitrate)
|
||||||
return hw_value_prefix | ath10k_rates[i].hw_value;
|
return hw_value_prefix | ath10k_rates[i].hw_value;
|
||||||
}
|
}
|
||||||
@@ -5699,22 +5699,22 @@ static void ath10k_bss_info_changed(stru
|
@@ -5703,22 +5703,22 @@ static void ath10k_bss_info_changed(stru
|
||||||
return;
|
return;
|
||||||
}
|
}
|
||||||
|
|
||||||
|
@ -17,7 +17,7 @@ Origin: other, https://patchwork.kernel.org/patch/10723033/
|
|||||||
|
|
||||||
--- a/drivers/net/wireless/ath/ath10k/mac.c
|
--- a/drivers/net/wireless/ath/ath10k/mac.c
|
||||||
+++ b/drivers/net/wireless/ath/ath10k/mac.c
|
+++ b/drivers/net/wireless/ath/ath10k/mac.c
|
||||||
@@ -5484,8 +5484,8 @@ static void ath10k_bss_info_changed(stru
|
@@ -5488,8 +5488,8 @@ static void ath10k_bss_info_changed(stru
|
||||||
struct cfg80211_chan_def def;
|
struct cfg80211_chan_def def;
|
||||||
u32 vdev_param, pdev_param, slottime, preamble;
|
u32 vdev_param, pdev_param, slottime, preamble;
|
||||||
u16 bitrate, hw_value;
|
u16 bitrate, hw_value;
|
||||||
@ -28,7 +28,7 @@ Origin: other, https://patchwork.kernel.org/patch/10723033/
|
|||||||
enum nl80211_band band;
|
enum nl80211_band band;
|
||||||
const struct ieee80211_supported_band *sband;
|
const struct ieee80211_supported_band *sband;
|
||||||
|
|
||||||
@@ -5658,7 +5658,11 @@ static void ath10k_bss_info_changed(stru
|
@@ -5662,7 +5662,11 @@ static void ath10k_bss_info_changed(stru
|
||||||
if (changed & BSS_CHANGED_MCAST_RATE &&
|
if (changed & BSS_CHANGED_MCAST_RATE &&
|
||||||
!ath10k_mac_vif_chan(arvif->vif, &def)) {
|
!ath10k_mac_vif_chan(arvif->vif, &def)) {
|
||||||
band = def.chan->band;
|
band = def.chan->band;
|
||||||
|
@ -38,7 +38,7 @@ Forwarded: https://patchwork.kernel.org/patch/10986723/
|
|||||||
|
|
||||||
if (arvif->vdev_type == WMI_VDEV_TYPE_AP) {
|
if (arvif->vdev_type == WMI_VDEV_TYPE_AP) {
|
||||||
arg.ssid = arvif->u.ap.ssid;
|
arg.ssid = arvif->u.ap.ssid;
|
||||||
@@ -3139,7 +3139,7 @@ static int ath10k_update_channel_list(st
|
@@ -3143,7 +3143,7 @@ static int ath10k_update_channel_list(st
|
||||||
ch->min_power = 0;
|
ch->min_power = 0;
|
||||||
ch->max_power = channel->max_power * 2;
|
ch->max_power = channel->max_power * 2;
|
||||||
ch->max_reg_power = channel->max_reg_power * 2;
|
ch->max_reg_power = channel->max_reg_power * 2;
|
||||||
|
@ -89,7 +89,7 @@ Forwarded: no
|
|||||||
|
|
||||||
if (arvif->vdev_type == WMI_VDEV_TYPE_AP) {
|
if (arvif->vdev_type == WMI_VDEV_TYPE_AP) {
|
||||||
arg.ssid = arvif->u.ap.ssid;
|
arg.ssid = arvif->u.ap.ssid;
|
||||||
@@ -3139,7 +3175,8 @@ static int ath10k_update_channel_list(st
|
@@ -3143,7 +3179,8 @@ static int ath10k_update_channel_list(st
|
||||||
ch->min_power = 0;
|
ch->min_power = 0;
|
||||||
ch->max_power = channel->max_power * 2;
|
ch->max_power = channel->max_power * 2;
|
||||||
ch->max_reg_power = channel->max_reg_power * 2;
|
ch->max_reg_power = channel->max_reg_power * 2;
|
||||||
|
@ -77,7 +77,7 @@ Signed-off-by: Johannes Berg <johannes.berg@intel.com>
|
|||||||
|
|
||||||
atomic_t agg_queue_stop[IEEE80211_MAX_QUEUES];
|
atomic_t agg_queue_stop[IEEE80211_MAX_QUEUES];
|
||||||
|
|
||||||
@@ -2039,6 +2041,7 @@ void ieee80211_txq_remove_vlan(struct ie
|
@@ -2046,6 +2048,7 @@ void ieee80211_txq_remove_vlan(struct ie
|
||||||
struct ieee80211_sub_if_data *sdata);
|
struct ieee80211_sub_if_data *sdata);
|
||||||
void ieee80211_fill_txq_stats(struct cfg80211_txq_stats *txqstats,
|
void ieee80211_fill_txq_stats(struct cfg80211_txq_stats *txqstats,
|
||||||
struct txq_info *txqi);
|
struct txq_info *txqi);
|
||||||
|
Loading…
x
Reference in New Issue
Block a user