diff --git a/package/lqdsl/Config.in b/package/lqdsl/Config.in
deleted file mode 100644
index fe503b85382..00000000000
--- a/package/lqdsl/Config.in
+++ /dev/null
@@ -1,25 +0,0 @@
-
-choice
-	prompt "Firmware"
-	default LANTIQ_ANNEX_B
-	depends on PACKAGE_kmod-lqdsl
-	help
-	  This option controls which firmware is loaded
-
-config LANTIQ_ANNEX_A
-	bool "Annex-A"
-	help
-	  Annex-A
-
-config LANTIQ_ANNEX_B
-	bool "Annex-B"
-	help
-	  Annex-B
-
-endchoice
-
-config LANTIQ_DSL_DEBUG
-	bool "lqdsl debugging"
-	depends on PACKAGE_kmod-lqdsl
-	help
-	  Say Y, if you need lantiq-dsl to display debug messages.
diff --git a/package/lqdsl-app/Makefile b/package/ltq-dsl-app/Makefile
similarity index 87%
rename from package/lqdsl-app/Makefile
rename to package/ltq-dsl-app/Makefile
index 18ce2a9a542..5be052f6e20 100644
--- a/package/lqdsl-app/Makefile
+++ b/package/ltq-dsl-app/Makefile
@@ -1,10 +1,9 @@
 #
-# Copyright (C) 2009-2010 OpenWrt.org
+# Copyright (C) 2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# ralph / blogic
 
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
@@ -19,16 +18,16 @@ PKG_MD5SUM:=ee315306626b68794d3d3636dabfe161
 
 include $(INCLUDE_DIR)/package.mk
 
-define Package/lqdsl-app
+define Package/ltq-dsl-app
   SECTION:=net
   CATEGORY:=Network
   TITLE:=Lantiq DSL userland tool
   URL:=http://www.lantiq.com/
-  MAINTAINER:=Lantiq
-  DEPENDS:=@TARGET_lantiq_xway +kmod-lqdsl +libpthread
+  DEPENDS:=@TARGET_lantiq_xway +kmod-ltq-dsl +libpthread
+  MAINTAINER:=John Crispin <blogic@openwrt.org> 
 endef
 
-define Package/lqdsl-app/description
+define Package/ltq-dsl-app/description
 	Infineon DSL CPE API for Amazon SE, Danube and Vinax.
 endef
 
@@ -70,7 +69,7 @@ endif
 
 TARGET_CFLAGS += -I$(LINUX_DIR)/include
 
-define Package/lqdsl-app/install
+define Package/ltq-dsl-app/install
 	$(INSTALL_DIR) $(1)/etc/init.d
 	$(INSTALL_BIN) ./files/ifx_cpe_control_init.sh $(1)/etc/init.d/
 
@@ -78,4 +77,4 @@ define Package/lqdsl-app/install
 	$(INSTALL_BIN) $(PKG_BUILD_DIR)/src/dsl_cpe_control $(1)/sbin
 endef
 
-$(eval $(call BuildPackage,lqdsl-app))
+$(eval $(call BuildPackage,ltq-dsl-app))
diff --git a/package/lqdsl-app/files/ifx_cpe_control_init.sh b/package/ltq-dsl-app/files/ifx_cpe_control_init.sh
similarity index 100%
rename from package/lqdsl-app/files/ifx_cpe_control_init.sh
rename to package/ltq-dsl-app/files/ifx_cpe_control_init.sh
diff --git a/package/ltq-dsl/Config.in b/package/ltq-dsl/Config.in
new file mode 100644
index 00000000000..6d9caf44190
--- /dev/null
+++ b/package/ltq-dsl/Config.in
@@ -0,0 +1,5 @@
+config LANTIQ_DSL_DEBUG
+	bool "verbose debugging"
+	depends on PACKAGE_kmod-ltq-dsl
+	help
+	  Say Y, if you need ltq-dsl to display debug messages.
diff --git a/package/lqdsl/Makefile b/package/ltq-dsl/Makefile
similarity index 76%
rename from package/lqdsl/Makefile
rename to package/ltq-dsl/Makefile
index bfadd7150dc..6f8f6ba0c61 100644
--- a/package/lqdsl/Makefile
+++ b/package/ltq-dsl/Makefile
@@ -1,15 +1,14 @@
 #
-# Copyright (C) 2009-2010 OpenWrt.org
+# Copyright (C) 2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# ralph / blogic
 
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
-PKG_NAME:=lqdsl
+PKG_NAME:=ltq-dsl
 PKG_BASE_NAME:=drv_dsl_cpe_api_danube
 PKG_VERSION:=3.24.4.4
 PKG_RELEASE:=2
@@ -18,10 +17,6 @@ PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/drv_dsl_cpe_api-$(PKG_VERSION)
 PKG_SOURCE_URL:=http://mirror2.openwrt.org/sources/
 PKG_MD5SUM:=c45bc531c1ed2ac80f68fb986b63bb87
 
-ifeq ($(DUMP),)
-  STAMP_CONFIGURED:=$(strip $(STAMP_CONFIGURED))_$(shell grep '^CONFIG_LANTIQ_DSL_' $(TOPDIR)/.config | md5s)
-endif
-
 FW_BASE_NAME:=dsl_danube_firmware_adsl
 FW_A_VER:=02.04.04.00.00.01
 FW_B_VER:=02.04.01.07.00.02
@@ -30,35 +25,47 @@ FW_B_FILE_VER:=241702
 FW_A_MD5:=f717db3067a0049a26e233ab11238710
 FW_B_MD5:=349de7cd20368f4ac9b7e8322114a512
 
-PATCH_DIR ?= ./patches$(if $(wildcard ./patches-$(KERNEL_PATCHVER)),-$(KERNEL_PATCHVER))
-
 include $(INCLUDE_DIR)/package.mk
 
-define KernelPackage/lqdsl
+define KernelPackage/ltq-dsl
   SECTION:=sys
   CATEGORY:=Kernel modules
   SUBMENU:=Network Devices
   TITLE:=Lantiq dsl driver
   URL:=http://www.lantiq.com/
-  MAINTAINER:=Lantiq 
   DEPENDS:=@TARGET_lantiq_xway +kmod-atm
   FILES:=$(PKG_BUILD_DIR)/src/mei/lantiq_mei.ko \
 	$(PKG_BUILD_DIR)/src/drv_dsl_cpe_api.ko \
 	$(PKG_BUILD_DIR)/src/mei/lantiq_atm.ko
   AUTOLOAD:=$(call AutoLoad,50,lantiq_mei drv_dsl_cpe_api lantiq_atm)
+  MAINTAINER:=John Crispin <blogic@openwrt.org>
 endef
 
-define KernelPackage/lqdsl/description
-	Infineon DSL CPE API for Amazon SE, Danube and Vinax.
-
-	This package contains the DSL CPE API driver for Amazon SE & Danube.
-	
-	Supported Devices:
-		- Amazon SE
-		- Danube 
+define Package/kmod-ltq-dsl-firmware/default
+  SECTION:=sys
+  CATEGORY:=Kernel modules
+  SUBMENU:=Network Devices
+  TITLE:=Firmware
+  URL:=http://www.lantiq.com/
+  DEPENDS:=@TARGET_lantiq_xway kmod-ltq-dsl
+  MAINTAINER:=John Crispin <blogic@openwrt.org>
 endef
 
-define KernelPackage/lqdsl/config
+define Package/kmod-ltq-dsl-firmware-a
+  $(call Package/kmod-ltq-dsl-firmware/default)
+  TITLE+=Annex-A Danube
+endef
+
+define Package/kmod-ltq-dsl-firmware-b
+  $(call Package/kmod-ltq-dsl-firmware/default)
+  TITLE+=Annex-B Danube
+endef
+
+define KernelPackage/ltq-dsl/description
+	Lantiq DSL CPE API for Amazon SE, Danube and Vinax.
+endef
+
+define KernelPackage/ltq-dsl/config
 	source "$(SOURCE)/Config.in"
 endef
 
@@ -118,10 +125,8 @@ define Build/Prepare
 	$(INSTALL_DIR) $(PKG_BUILD_DIR)/src/mei/ 
 	$(CP) ./src/* $(PKG_BUILD_DIR)/src/mei/
 	$(Build/Patch)
-ifeq ($(CONFIG_LANTIQ_DSL_FIRMWARE),)
 	$(TAR) -C $(PKG_BUILD_DIR) -xzf $(DL_DIR)/$(FW_BASE_NAME)_a-$(FW_A_VER).tar.gz
 	$(TAR) -C $(PKG_BUILD_DIR) -xzf $(DL_DIR)/$(FW_BASE_NAME)_b-$(FW_B_VER).tar.gz
-endif
 endef
 
 define Build/Configure
@@ -150,9 +155,16 @@ define Build/InstallDev
 	$(CP) $(PKG_BUILD_DIR)/src/include/drv_dsl_cpe_cmv_danube.h $(1)/usr/include
 endef
 
-define KernelPackage/lqdsl/install
+define Package/ltq-dsl-firmware-a/install
 	$(INSTALL_DIR) $(1)/lib/firmware/
-	$(CP) $(PKG_BUILD_DIR)/$(FW_BASE_NAME)_$(if $(CONFIG_LANTIQ_ANNEX_A),a_$(FW_A_FILE_VER),b_$(FW_B_FILE_VER)).bin $(1)/lib/firmware/ModemHWE.bin
+	$(CP) $(PKG_BUILD_DIR)/$(FW_BASE_NAME)_a_$(FW_A_FILE_VER).bin $(1)/lib/firmware/ModemHWE.bin
 endef
 
-$(eval $(call KernelPackage,lqdsl))
+define Package/ltq-dsl-firmware-b/install
+	$(INSTALL_DIR) $(1)/lib/firmware/
+	$(CP) $(PKG_BUILD_DIR)/$(FW_BASE_NAME)_b_$(FW_B_FILE_VER).bin $(1)/lib/firmware/ModemHWE.bin
+endef
+
+$(eval $(call KernelPackage,ltq-dsl))
+$(eval $(call BuildPackage,kmod-ltq-dsl-firmware-a))
+$(eval $(call BuildPackage,kmod-ltq-dsl-firmware-b))
diff --git a/package/lqdsl/patches/100-dsl_compat.patch b/package/ltq-dsl/patches/100-dsl_compat.patch
similarity index 100%
rename from package/lqdsl/patches/100-dsl_compat.patch
rename to package/ltq-dsl/patches/100-dsl_compat.patch
diff --git a/package/lqdsl/patches/500-portability.patch b/package/ltq-dsl/patches/500-portability.patch
similarity index 100%
rename from package/lqdsl/patches/500-portability.patch
rename to package/ltq-dsl/patches/500-portability.patch
diff --git a/package/lqdsl/src/Makefile b/package/ltq-dsl/src/Makefile
similarity index 100%
rename from package/lqdsl/src/Makefile
rename to package/ltq-dsl/src/Makefile
diff --git a/package/lqdsl/src/ifx_atm.h b/package/ltq-dsl/src/ifx_atm.h
similarity index 100%
rename from package/lqdsl/src/ifx_atm.h
rename to package/ltq-dsl/src/ifx_atm.h
diff --git a/package/lqdsl/src/ifxmips_atm.h b/package/ltq-dsl/src/ifxmips_atm.h
similarity index 100%
rename from package/lqdsl/src/ifxmips_atm.h
rename to package/ltq-dsl/src/ifxmips_atm.h
diff --git a/package/lqdsl/src/ifxmips_atm_core.c b/package/ltq-dsl/src/ifxmips_atm_core.c
similarity index 100%
rename from package/lqdsl/src/ifxmips_atm_core.c
rename to package/ltq-dsl/src/ifxmips_atm_core.c
diff --git a/package/lqdsl/src/ifxmips_atm_core.h b/package/ltq-dsl/src/ifxmips_atm_core.h
similarity index 100%
rename from package/lqdsl/src/ifxmips_atm_core.h
rename to package/ltq-dsl/src/ifxmips_atm_core.h
diff --git a/package/lqdsl/src/ifxmips_atm_danube.c b/package/ltq-dsl/src/ifxmips_atm_danube.c
similarity index 100%
rename from package/lqdsl/src/ifxmips_atm_danube.c
rename to package/ltq-dsl/src/ifxmips_atm_danube.c
diff --git a/package/lqdsl/src/ifxmips_atm_fw_danube.h b/package/ltq-dsl/src/ifxmips_atm_fw_danube.h
similarity index 100%
rename from package/lqdsl/src/ifxmips_atm_fw_danube.h
rename to package/ltq-dsl/src/ifxmips_atm_fw_danube.h
diff --git a/package/lqdsl/src/ifxmips_atm_fw_regs_common.h b/package/ltq-dsl/src/ifxmips_atm_fw_regs_common.h
similarity index 100%
rename from package/lqdsl/src/ifxmips_atm_fw_regs_common.h
rename to package/ltq-dsl/src/ifxmips_atm_fw_regs_common.h
diff --git a/package/lqdsl/src/ifxmips_atm_fw_regs_danube.h b/package/ltq-dsl/src/ifxmips_atm_fw_regs_danube.h
similarity index 100%
rename from package/lqdsl/src/ifxmips_atm_fw_regs_danube.h
rename to package/ltq-dsl/src/ifxmips_atm_fw_regs_danube.h
diff --git a/package/lqdsl/src/ifxmips_atm_ppe_common.h b/package/ltq-dsl/src/ifxmips_atm_ppe_common.h
similarity index 100%
rename from package/lqdsl/src/ifxmips_atm_ppe_common.h
rename to package/ltq-dsl/src/ifxmips_atm_ppe_common.h
diff --git a/package/lqdsl/src/ifxmips_atm_ppe_danube.h b/package/ltq-dsl/src/ifxmips_atm_ppe_danube.h
similarity index 100%
rename from package/lqdsl/src/ifxmips_atm_ppe_danube.h
rename to package/ltq-dsl/src/ifxmips_atm_ppe_danube.h
diff --git a/package/lqdsl/src/ifxmips_compat.h b/package/ltq-dsl/src/ifxmips_compat.h
similarity index 100%
rename from package/lqdsl/src/ifxmips_compat.h
rename to package/ltq-dsl/src/ifxmips_compat.h
diff --git a/package/lqdsl/src/ifxmips_mei_interface.h b/package/ltq-dsl/src/ifxmips_mei_interface.h
similarity index 100%
rename from package/lqdsl/src/ifxmips_mei_interface.h
rename to package/ltq-dsl/src/ifxmips_mei_interface.h
diff --git a/package/lqdsl/src/lantiq_mei.c b/package/ltq-dsl/src/lantiq_mei.c
similarity index 100%
rename from package/lqdsl/src/lantiq_mei.c
rename to package/ltq-dsl/src/lantiq_mei.c