kernel: bump 4.14 to 4.14.221
Refreshed all patches. Remove upstreamed hunk in: - 302-dts-support-layerscape.patch Compile-tested on: ar71xx, cns3xxx, imx6, x86_64 Runtime-tested on: ar71xx, cns3xxx, imx6 Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
This commit is contained in:
parent
f8b849103d
commit
c4a6851c72
@ -6,9 +6,9 @@ ifdef CONFIG_TESTING_KERNEL
|
|||||||
KERNEL_PATCHVER:=$(KERNEL_TESTING_PATCHVER)
|
KERNEL_PATCHVER:=$(KERNEL_TESTING_PATCHVER)
|
||||||
endif
|
endif
|
||||||
|
|
||||||
LINUX_VERSION-4.14 = .219
|
LINUX_VERSION-4.14 = .221
|
||||||
|
|
||||||
LINUX_KERNEL_HASH-4.14.219 = 75eecaa731c091fcf3bc2ec914b01d299a447d78041cb66a11a2ab169eb801dd
|
LINUX_KERNEL_HASH-4.14.221 = ce2254075ff4846f13380c1cf4bec1e351e5996a7dd109c200e222e49fd2c7e9
|
||||||
|
|
||||||
remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
|
remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
|
||||||
sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
|
sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
|
||||||
|
@ -30,7 +30,7 @@ Signed-off-by: Johan Hovold <johan@kernel.org>
|
|||||||
|
|
||||||
--- a/drivers/usb/serial/option.c
|
--- a/drivers/usb/serial/option.c
|
||||||
+++ b/drivers/usb/serial/option.c
|
+++ b/drivers/usb/serial/option.c
|
||||||
@@ -2017,7 +2017,8 @@ static const struct usb_device_id option
|
@@ -2023,7 +2023,8 @@ static const struct usb_device_id option
|
||||||
{ USB_DEVICE_INTERFACE_CLASS(0x2001, 0x7d01, 0xff) }, /* D-Link DWM-156 (variant) */
|
{ USB_DEVICE_INTERFACE_CLASS(0x2001, 0x7d01, 0xff) }, /* D-Link DWM-156 (variant) */
|
||||||
{ USB_DEVICE_INTERFACE_CLASS(0x2001, 0x7d02, 0xff) },
|
{ USB_DEVICE_INTERFACE_CLASS(0x2001, 0x7d02, 0xff) },
|
||||||
{ USB_DEVICE_INTERFACE_CLASS(0x2001, 0x7d03, 0xff) },
|
{ USB_DEVICE_INTERFACE_CLASS(0x2001, 0x7d03, 0xff) },
|
||||||
|
@ -15,7 +15,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
|
|||||||
|
|
||||||
--- a/Makefile
|
--- a/Makefile
|
||||||
+++ b/Makefile
|
+++ b/Makefile
|
||||||
@@ -1260,7 +1260,6 @@ endif
|
@@ -1254,7 +1254,6 @@ endif
|
||||||
|
|
||||||
PHONY += modules
|
PHONY += modules
|
||||||
modules: $(vmlinux-dirs) $(if $(KBUILD_BUILTIN),vmlinux) modules.builtin
|
modules: $(vmlinux-dirs) $(if $(KBUILD_BUILTIN),vmlinux) modules.builtin
|
||||||
@ -23,7 +23,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
|
|||||||
@$(kecho) ' Building modules, stage 2.';
|
@$(kecho) ' Building modules, stage 2.';
|
||||||
$(Q)$(MAKE) -f $(srctree)/scripts/Makefile.modpost
|
$(Q)$(MAKE) -f $(srctree)/scripts/Makefile.modpost
|
||||||
|
|
||||||
@@ -1289,7 +1288,6 @@ _modinst_:
|
@@ -1283,7 +1282,6 @@ _modinst_:
|
||||||
rm -f $(MODLIB)/build ; \
|
rm -f $(MODLIB)/build ; \
|
||||||
ln -s $(CURDIR) $(MODLIB)/build ; \
|
ln -s $(CURDIR) $(MODLIB)/build ; \
|
||||||
fi
|
fi
|
||||||
|
@ -44,7 +44,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
|
|||||||
device, it has to decide which ones to send first, which ones to
|
device, it has to decide which ones to send first, which ones to
|
||||||
--- a/net/sched/sch_api.c
|
--- a/net/sched/sch_api.c
|
||||||
+++ b/net/sched/sch_api.c
|
+++ b/net/sched/sch_api.c
|
||||||
@@ -2031,7 +2031,7 @@ static int __init pktsched_init(void)
|
@@ -2032,7 +2032,7 @@ static int __init pktsched_init(void)
|
||||||
return err;
|
return err;
|
||||||
}
|
}
|
||||||
|
|
||||||
|
@ -54,7 +54,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
|
|||||||
depends on BROKEN || !FRV
|
depends on BROKEN || !FRV
|
||||||
--- a/kernel/Makefile
|
--- a/kernel/Makefile
|
||||||
+++ b/kernel/Makefile
|
+++ b/kernel/Makefile
|
||||||
@@ -110,6 +110,7 @@ obj-$(CONFIG_CONTEXT_TRACKING) += contex
|
@@ -109,6 +109,7 @@ obj-$(CONFIG_CONTEXT_TRACKING) += contex
|
||||||
obj-$(CONFIG_TORTURE_TEST) += torture.o
|
obj-$(CONFIG_TORTURE_TEST) += torture.o
|
||||||
|
|
||||||
obj-$(CONFIG_HAS_IOMEM) += memremap.o
|
obj-$(CONFIG_HAS_IOMEM) += memremap.o
|
||||||
|
@ -62,7 +62,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
|
|||||||
|
|
||||||
--- a/drivers/base/core.c
|
--- a/drivers/base/core.c
|
||||||
+++ b/drivers/base/core.c
|
+++ b/drivers/base/core.c
|
||||||
@@ -162,10 +162,10 @@ static int device_reorder_to_tail(struct
|
@@ -177,10 +177,10 @@ static int device_reorder_to_tail(struct
|
||||||
* of the link. If DL_FLAG_PM_RUNTIME is not set, DL_FLAG_RPM_ACTIVE will be
|
* of the link. If DL_FLAG_PM_RUNTIME is not set, DL_FLAG_RPM_ACTIVE will be
|
||||||
* ignored.
|
* ignored.
|
||||||
*
|
*
|
||||||
@ -77,7 +77,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
|
|||||||
*
|
*
|
||||||
* A side effect of the link creation is re-ordering of dpm_list and the
|
* A side effect of the link creation is re-ordering of dpm_list and the
|
||||||
* devices_kset list by moving the consumer device and all devices depending
|
* devices_kset list by moving the consumer device and all devices depending
|
||||||
@@ -183,7 +183,8 @@ struct device_link *device_link_add(stru
|
@@ -198,7 +198,8 @@ struct device_link *device_link_add(stru
|
||||||
bool rpm_put_supplier = false;
|
bool rpm_put_supplier = false;
|
||||||
|
|
||||||
if (!consumer || !supplier ||
|
if (!consumer || !supplier ||
|
||||||
@ -87,7 +87,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
|
|||||||
return NULL;
|
return NULL;
|
||||||
|
|
||||||
if (flags & DL_FLAG_PM_RUNTIME && flags & DL_FLAG_RPM_ACTIVE) {
|
if (flags & DL_FLAG_PM_RUNTIME && flags & DL_FLAG_RPM_ACTIVE) {
|
||||||
@@ -209,8 +210,10 @@ struct device_link *device_link_add(stru
|
@@ -224,8 +225,10 @@ struct device_link *device_link_add(stru
|
||||||
}
|
}
|
||||||
|
|
||||||
list_for_each_entry(link, &supplier->links.consumers, s_node)
|
list_for_each_entry(link, &supplier->links.consumers, s_node)
|
||||||
@ -99,7 +99,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
|
|||||||
|
|
||||||
link = kzalloc(sizeof(*link), GFP_KERNEL);
|
link = kzalloc(sizeof(*link), GFP_KERNEL);
|
||||||
if (!link)
|
if (!link)
|
||||||
@@ -237,6 +240,7 @@ struct device_link *device_link_add(stru
|
@@ -252,6 +255,7 @@ struct device_link *device_link_add(stru
|
||||||
link->consumer = consumer;
|
link->consumer = consumer;
|
||||||
INIT_LIST_HEAD(&link->c_node);
|
INIT_LIST_HEAD(&link->c_node);
|
||||||
link->flags = flags;
|
link->flags = flags;
|
||||||
@ -107,7 +107,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
|
|||||||
|
|
||||||
/* Determine the initial link state. */
|
/* Determine the initial link state. */
|
||||||
if (flags & DL_FLAG_STATELESS) {
|
if (flags & DL_FLAG_STATELESS) {
|
||||||
@@ -311,8 +315,10 @@ static void __device_link_free_srcu(stru
|
@@ -326,8 +330,10 @@ static void __device_link_free_srcu(stru
|
||||||
device_link_free(container_of(rhead, struct device_link, rcu_head));
|
device_link_free(container_of(rhead, struct device_link, rcu_head));
|
||||||
}
|
}
|
||||||
|
|
||||||
@ -119,7 +119,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
|
|||||||
dev_info(link->consumer, "Dropping the link to %s\n",
|
dev_info(link->consumer, "Dropping the link to %s\n",
|
||||||
dev_name(link->supplier));
|
dev_name(link->supplier));
|
||||||
|
|
||||||
@@ -324,8 +330,10 @@ static void __device_link_del(struct dev
|
@@ -339,8 +345,10 @@ static void __device_link_del(struct dev
|
||||||
call_srcu(&device_links_srcu, &link->rcu_head, __device_link_free_srcu);
|
call_srcu(&device_links_srcu, &link->rcu_head, __device_link_free_srcu);
|
||||||
}
|
}
|
||||||
#else /* !CONFIG_SRCU */
|
#else /* !CONFIG_SRCU */
|
||||||
@ -131,7 +131,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
|
|||||||
dev_info(link->consumer, "Dropping the link to %s\n",
|
dev_info(link->consumer, "Dropping the link to %s\n",
|
||||||
dev_name(link->supplier));
|
dev_name(link->supplier));
|
||||||
|
|
||||||
@@ -343,18 +351,50 @@ static void __device_link_del(struct dev
|
@@ -358,18 +366,50 @@ static void __device_link_del(struct dev
|
||||||
* @link: Device link to delete.
|
* @link: Device link to delete.
|
||||||
*
|
*
|
||||||
* The caller must ensure proper synchronization of this function with runtime
|
* The caller must ensure proper synchronization of this function with runtime
|
||||||
@ -184,7 +184,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
|
|||||||
static void device_links_missing_supplier(struct device *dev)
|
static void device_links_missing_supplier(struct device *dev)
|
||||||
{
|
{
|
||||||
struct device_link *link;
|
struct device_link *link;
|
||||||
@@ -462,8 +502,8 @@ static void __device_links_no_driver(str
|
@@ -477,8 +517,8 @@ static void __device_links_no_driver(str
|
||||||
if (link->flags & DL_FLAG_STATELESS)
|
if (link->flags & DL_FLAG_STATELESS)
|
||||||
continue;
|
continue;
|
||||||
|
|
||||||
@ -195,7 +195,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
|
|||||||
else if (link->status != DL_STATE_SUPPLIER_UNBIND)
|
else if (link->status != DL_STATE_SUPPLIER_UNBIND)
|
||||||
WRITE_ONCE(link->status, DL_STATE_AVAILABLE);
|
WRITE_ONCE(link->status, DL_STATE_AVAILABLE);
|
||||||
}
|
}
|
||||||
@@ -498,8 +538,18 @@ void device_links_driver_cleanup(struct
|
@@ -513,8 +553,18 @@ void device_links_driver_cleanup(struct
|
||||||
if (link->flags & DL_FLAG_STATELESS)
|
if (link->flags & DL_FLAG_STATELESS)
|
||||||
continue;
|
continue;
|
||||||
|
|
||||||
@ -215,7 +215,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
|
|||||||
WRITE_ONCE(link->status, DL_STATE_DORMANT);
|
WRITE_ONCE(link->status, DL_STATE_DORMANT);
|
||||||
}
|
}
|
||||||
|
|
||||||
@@ -616,13 +666,13 @@ static void device_links_purge(struct de
|
@@ -631,13 +681,13 @@ static void device_links_purge(struct de
|
||||||
|
|
||||||
list_for_each_entry_safe_reverse(link, ln, &dev->links.suppliers, c_node) {
|
list_for_each_entry_safe_reverse(link, ln, &dev->links.suppliers, c_node) {
|
||||||
WARN_ON(link->status == DL_STATE_ACTIVE);
|
WARN_ON(link->status == DL_STATE_ACTIVE);
|
||||||
@ -231,7 +231,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
|
|||||||
}
|
}
|
||||||
|
|
||||||
device_links_write_unlock();
|
device_links_write_unlock();
|
||||||
@@ -1044,6 +1094,34 @@ static ssize_t online_store(struct devic
|
@@ -1059,6 +1109,34 @@ static ssize_t online_store(struct devic
|
||||||
}
|
}
|
||||||
static DEVICE_ATTR_RW(online);
|
static DEVICE_ATTR_RW(online);
|
||||||
|
|
||||||
@ -266,7 +266,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
|
|||||||
int device_add_groups(struct device *dev, const struct attribute_group **groups)
|
int device_add_groups(struct device *dev, const struct attribute_group **groups)
|
||||||
{
|
{
|
||||||
return sysfs_create_groups(&dev->kobj, groups);
|
return sysfs_create_groups(&dev->kobj, groups);
|
||||||
@@ -1215,8 +1293,20 @@ static int device_add_attrs(struct devic
|
@@ -1230,8 +1308,20 @@ static int device_add_attrs(struct devic
|
||||||
goto err_remove_dev_groups;
|
goto err_remove_dev_groups;
|
||||||
}
|
}
|
||||||
|
|
||||||
@ -287,7 +287,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
|
|||||||
err_remove_dev_groups:
|
err_remove_dev_groups:
|
||||||
device_remove_groups(dev, dev->groups);
|
device_remove_groups(dev, dev->groups);
|
||||||
err_remove_type_groups:
|
err_remove_type_groups:
|
||||||
@@ -1234,6 +1324,8 @@ static void device_remove_attrs(struct d
|
@@ -1249,6 +1339,8 @@ static void device_remove_attrs(struct d
|
||||||
struct class *class = dev->class;
|
struct class *class = dev->class;
|
||||||
const struct device_type *type = dev->type;
|
const struct device_type *type = dev->type;
|
||||||
|
|
||||||
|
@ -4662,15 +4662,6 @@ Signed-off-by: Zhao Qiang <qiang.zhao@nxp.com>
|
|||||||
scfg: scfg@1570000 {
|
scfg: scfg@1570000 {
|
||||||
compatible = "fsl,ls1046a-scfg", "syscon";
|
compatible = "fsl,ls1046a-scfg", "syscon";
|
||||||
reg = <0x0 0x1570000 0x0 0x10000>;
|
reg = <0x0 0x1570000 0x0 0x10000>;
|
||||||
@@ -304,7 +311,7 @@
|
|
||||||
|
|
||||||
dcfg: dcfg@1ee0000 {
|
|
||||||
compatible = "fsl,ls1046a-dcfg", "syscon";
|
|
||||||
- reg = <0x0 0x1ee0000 0x0 0x10000>;
|
|
||||||
+ reg = <0x0 0x1ee0000 0x0 0x1000>;
|
|
||||||
big-endian;
|
|
||||||
};
|
|
||||||
|
|
||||||
@@ -362,36 +369,7 @@
|
@@ -362,36 +369,7 @@
|
||||||
#thermal-sensor-cells = <1>;
|
#thermal-sensor-cells = <1>;
|
||||||
};
|
};
|
||||||
|
@ -1289,7 +1289,7 @@ Signed-off-by: Zhao Chenhui <chenhui.zhao@freescale.com>
|
|||||||
xhci->quirks |= XHCI_BROKEN_PORT_PED;
|
xhci->quirks |= XHCI_BROKEN_PORT_PED;
|
||||||
--- a/drivers/usb/host/xhci-ring.c
|
--- a/drivers/usb/host/xhci-ring.c
|
||||||
+++ b/drivers/usb/host/xhci-ring.c
|
+++ b/drivers/usb/host/xhci-ring.c
|
||||||
@@ -1978,10 +1978,12 @@ static int finish_td(struct xhci_hcd *xh
|
@@ -1983,10 +1983,12 @@ static int finish_td(struct xhci_hcd *xh
|
||||||
union xhci_trb *ep_trb, struct xhci_transfer_event *event,
|
union xhci_trb *ep_trb, struct xhci_transfer_event *event,
|
||||||
struct xhci_virt_ep *ep, int *status)
|
struct xhci_virt_ep *ep, int *status)
|
||||||
{
|
{
|
||||||
@ -1302,7 +1302,7 @@ Signed-off-by: Zhao Chenhui <chenhui.zhao@freescale.com>
|
|||||||
u32 trb_comp_code;
|
u32 trb_comp_code;
|
||||||
int ep_index;
|
int ep_index;
|
||||||
|
|
||||||
@@ -2004,14 +2006,30 @@ static int finish_td(struct xhci_hcd *xh
|
@@ -2009,14 +2011,30 @@ static int finish_td(struct xhci_hcd *xh
|
||||||
if (trb_comp_code == COMP_STALL_ERROR ||
|
if (trb_comp_code == COMP_STALL_ERROR ||
|
||||||
xhci_requires_manual_halt_cleanup(xhci, ep_ctx,
|
xhci_requires_manual_halt_cleanup(xhci, ep_ctx,
|
||||||
trb_comp_code)) {
|
trb_comp_code)) {
|
||||||
|
Loading…
x
Reference in New Issue
Block a user