From cef30e225d366b9f48eef20eb57773b981dbbdea Mon Sep 17 00:00:00 2001
From: Christian Lamparter <chunkeey@gmail.com>
Date: Fri, 14 Jun 2024 17:05:47 +0200
Subject: [PATCH] uml: define "generic" subtarget

UML didn't have a subtarget defined.

While this compiled fine, the patch caused funny filenames
for the generated files to appear:
 - "openwrt-uml--vmlinux"
 - "openwrt-uml--squashfs.img"
 - "openwrt-uml--ext4.img"
 - ...

since "generic" is implied anyway, let's just set it.

Fixes: d997477775bf ("treewide: remove implicit SUBTARGET")
Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Link: https://github.com/openwrt/openwrt/pull/15713
Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
---
 target/linux/uml/Makefile          | 1 +
 target/linux/uml/README.md         | 2 +-
 target/linux/uml/generic/target.mk | 1 +
 3 files changed, 3 insertions(+), 1 deletion(-)
 create mode 100644 target/linux/uml/generic/target.mk

diff --git a/target/linux/uml/Makefile b/target/linux/uml/Makefile
index 307687ffda0..cad5d0f3d32 100644
--- a/target/linux/uml/Makefile
+++ b/target/linux/uml/Makefile
@@ -12,6 +12,7 @@ ARCH:=x86_64
 BOARD:=uml
 BOARDNAME:=User Mode Linux
 FEATURES:=audio ext4 rootfs-part squashfs
+SUBTARGETS:=generic
 
 KERNEL_PATCHVER:=6.1
 KERNEL_TESTING_PATCHVER:=6.6
diff --git a/target/linux/uml/README.md b/target/linux/uml/README.md
index 9275f9891b9..ffdd2f0fe71 100644
--- a/target/linux/uml/README.md
+++ b/target/linux/uml/README.md
@@ -20,7 +20,7 @@ In your bin directory you will find a Kernel and an root file system when it's
 finished. Just run it like this:-
 
 ```shell
-./openwrt-uml-vmlinux ubd0=openwrt-uml-squashfs.img
+./openwrt-uml-generic-vmlinux ubd0=openwrt-uml-generic-squashfs.img
 ```
 
 The uml will start and eventually the serial console of the uml will be at your
diff --git a/target/linux/uml/generic/target.mk b/target/linux/uml/generic/target.mk
new file mode 100644
index 00000000000..f5cb1fb19b9
--- /dev/null
+++ b/target/linux/uml/generic/target.mk
@@ -0,0 +1 @@
+BOARDNAME:=Generic