From d61d82e3d35e2323645f56a99018b4a79244e0ba Mon Sep 17 00:00:00 2001
From: Jonas Gorski <jonas.gorski@gmail.com>
Date: Sat, 18 Jun 2016 13:38:46 +0200
Subject: [PATCH] brcm63xx: merge DSL-274X-F1 profiles

The only difference is a field in the image tag header, so just define
two images for it instead of treating them as separate devices.

Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com>
---
 target/linux/brcm63xx/image/bcm63xx.mk | 22 ++++++----------------
 1 file changed, 6 insertions(+), 16 deletions(-)

diff --git a/target/linux/brcm63xx/image/bcm63xx.mk b/target/linux/brcm63xx/image/bcm63xx.mk
index 80104f12e9a..a4dd2feb9e2 100644
--- a/target/linux/brcm63xx/image/bcm63xx.mk
+++ b/target/linux/brcm63xx/image/bcm63xx.mk
@@ -485,29 +485,19 @@ define Device/DSL274XB-C3
 endef
 TARGET_DEVICES += DSL274XB-C3
 
-define Device/DSL274XB-F1-AU
+define Device/DSL274XB-F1
   $(Device/bcm63xx)
-  DEVICE_TITLE := D-Link DSL-2740B/DSL-2741B rev F1 (AU)
+  DEVICE_TITLE := D-Link DSL-2740B/DSL-2741B rev F1
   DEVICE_DTS := dsl-274xb-f
   CFE_BOARD_ID := AW4339U
   CFE_CHIP_ID := 6328
-  CFE_EXTRAS := --signature2 "4.06.01.AUF1" --pad 4
+  IMAGES := cfe-EU.bin cfe-AU.bin
+  IMAGE/cfe-AU.bin := cfe-bin --signature2 "4.06.01.AUF1" --pad 4
+  IMAGE/cfe-EU.bin := cfe-bin --signature2 "4.06.01.EUF1" --pad 4
   DEVICE_PACKAGES := \
     $(ATH9K_PACKAGES)
 endef
-TARGET_DEVICES += DSL274XB-F1-AU
-
-define Device/DSL274XB-F1-EU
-  $(Device/bcm63xx)
-  DEVICE_TITLE := D-Link DSL-2740B/DSL-2741B rev F1 (EU)
-  DEVICE_DTS := dsl-274xb-f
-  CFE_BOARD_ID := AW4339U
-  CFE_CHIP_ID := 6328
-  CFE_EXTRAS := --signature2 "4.06.01.EUF1" --pad 4
-  DEVICE_PACKAGES := \
-    $(ATH9K_PACKAGES)
-endef
-TARGET_DEVICES += DSL274XB-F1-EU
+TARGET_DEVICES += DSL274XB-F1
 
 define Device/DSL275XB-D1
   $(Device/bcm63xx)