From fc0c518a88e68d3deef04bec73b33d35186d6546 Mon Sep 17 00:00:00 2001
From: Hannu Nyman <hannu.nyman@iki.fi>
Date: Sun, 1 Dec 2024 13:07:05 +0200
Subject: [PATCH] busybox: Fix cron log level to match previous behavior

Change the cron log level in init script from 5 to 7
in order to match previous log behavior and to avoid
log spam every minute.

Busybox cron only uses levels 5,7,8, where 5 is debug and
7 and 8 are normal logging. Use 7 as default.

(Fun note: this is needed because upstream corrected an
ancient bug in their own log level handling and now 5 actually
means something.)

Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>
Link: https://github.com/openwrt/openwrt/pull/17107
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
---
 package/utils/busybox/Makefile   | 2 +-
 package/utils/busybox/files/cron | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)

diff --git a/package/utils/busybox/Makefile b/package/utils/busybox/Makefile
index 7094b1e22db..4f155b7a250 100644
--- a/package/utils/busybox/Makefile
+++ b/package/utils/busybox/Makefile
@@ -6,7 +6,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=busybox
 PKG_VERSION:=1.37.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_FLAGS:=essential
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
diff --git a/package/utils/busybox/files/cron b/package/utils/busybox/files/cron
index 4efdfa52cad..2ddffa61e48 100755
--- a/package/utils/busybox/files/cron
+++ b/package/utils/busybox/files/cron
@@ -28,7 +28,7 @@ start_service() {
 	ln -s /etc/crontabs /var/spool/cron/ 2>/dev/null
 
 	procd_open_instance
-	procd_set_param command "$PROG" -f -c /etc/crontabs -l "${loglevel:-5}"
+	procd_set_param command "$PROG" -f -c /etc/crontabs -l "${loglevel:-7}"
 	for crontab in /etc/crontabs/*; do
 		 procd_set_param file "$crontab"
 	done